Dodge SRT Forum banner

1 - 20 of 26 Posts

·
Registered
Joined
·
2,892 Posts
Discussion Starter · #1 ·
Was driving home form the MOST FUN DAY EVER (seperate thread for that wet dream come true...) and was gunning it in 2nd. Went to shift hard into third and all i got was brmbmrmbrmrmb pop pop pop....rev limiter. I couldn't get any gear. Coasted all the way into a park parking lot and parked it. With car running I can move shifter from 3rd to 4th easily w/ out clutch but cannot move it enough side to side to get 1/2 or 5/R. Being 2 a.m. I was prettty pissed and the only thing I did was pop off the boot to check the linkage and bushings. Both bushings are securely on there. My only guess is that bushigs on tranny side popped off or I snapped the cable(s). Thoughts, opinions?? Oh and I have the mopar STS.
 

·
Registered
Joined
·
5,564 Posts
sounds like tranny side to me
 

·
Registered
Joined
·
153 Posts
Yeah check the side to side movement cable bushing on the tranny side. Did you install the BB? If so I 'really' had to clamp down on em to get them all the way on. I used a set of plumbers pliers (Channel Locks) to get them all the way on, and even then it took a bit of force. If they didn't 'snap' when you popped them in they weren't seated. I can't see how they could come off on their own if they were. At least not the BB's, maybe the stockers.
 

·
Registered
Joined
·
1,363 Posts
Hey Uhprentis are you talking about the bushings on the inside shifter or the bushings under the battery?

Ive heard the passenger side bushing on the inside is a bitch to get on there.
 

·
Registered
Joined
·
2,892 Posts
Discussion Starter · #5 ·
no i don't have the booger bushings. I looked @ the bushings on the tranny side and both are on securely. (never been removed) I had my friend shift as I watched the tranny side and the left cable/ bushing moves that toggle thingy and the right one just kinda twitches :stab:
 

·
Registered
Joined
·
1,363 Posts
... how many miles on your car? any hard launches? ever grind any gears?
 

·
Registered
Joined
·
2,892 Posts
Discussion Starter · #7 ·
31K miles. Maybe 20-25 track launches, several street launches, RAREly gring gears (maybe like 8 times total, and that is being liberal)
 

·
Registered
Joined
·
1,363 Posts
8 grinds?!

Ive only grinded one gear in my life and that was on a 1992 Integra LS the day I learned to drive stick...

What gear did you grind each time?
 

·
Registered
Joined
·
3,464 Posts
I think I've grinded going into 2nd twice. Horrible feeling.
 

·
Registered
Joined
·
2,892 Posts
Discussion Starter · #10 ·
En-Glaived said:
8 grinds?!

Ive only grinded one gear in my life and that was on a 1992 Integra LS the day I learned to drive stick...

What gear did you grind each time?
well I said being liberal....2 bad ones, the rest were more like mis-shifts that might have grinded a LILLTE bit...dunno for sure
 

·
Registered
Joined
·
1,363 Posts
I dont think it has to due with the cables... Did it make any noise when it happened? Or you had music on or was your exhaust/turbo to loud?
 

·
Registered
Joined
·
2,892 Posts
Discussion Starter · #12 ·
no noise other than the engine bouncing off redling for a second when it happened.....
 

·
Registered
Joined
·
2,892 Posts
Discussion Starter · #13 ·
well had Dodge tow it to Feeny.....don't really like them but the tow was free so......I guess I'll just have to hope for a warranty..... :eeeek:
 

·
Registered
Joined
·
1,363 Posts
No penny in a blender noises when it happened? Either you fried your clutch or you stripped a gear man.
 

·
Registered
Joined
·
2,892 Posts
Discussion Starter · #15 ·
En-Glaived said:
No penny in a blender noises when it happened? Either you fried your clutch or you stripped a gear man.
newp...no noises whatsoever. I can start it and shift into ANY gear w/out using clutch...no noises. It just stays in neutral no matter what. CLutch feels normal.
 

·
Registered
Joined
·
153 Posts
En-Glaived said:
Hey Uhprentis are you talking about the bushings on the inside shifter or the bushings under the battery?

Ive heard the passenger side bushing on the inside is a bitch to get on there.
Aye, the passenger side under the shifter is bad, the one attached to the trasmission, under the battery are just as bad if not worse because of placement.
 

·
Registered
Joined
·
2,892 Posts
Discussion Starter · #17 ·
ya they are, I've installed 4 STS and bogger bushings. Luckily I could see them working, (or NOT working as might be the case) w/out having to take shit off.
 

·
Registered
Joined
·
755 Posts
I had that exact thing happen. What mine was, a roll pin that connects the shifter cable bracket to the bar that turns giong in the top of the transmission worked it's way half out, and finally broke. Sorry for not knowing the technicl words, but it is what connected the round bar that sticks out of the top of the transmission to the bracket, which the shifter cable is connected to. PITA to get too (cuz i didnt want to remove the battery) but an easy fix. Just need to buy a new roll pin.

Is your car still in your possesion? You can barely see it, look where the cables connect to the trans under the hood. Have a friend move your stick around, and you can see that one side will be turning the bar going in the motor, the other one wont.

Has your stick felt a bit..sloppy lately? For about 2 months before it finally snaped, my stick would....wiggle... a bit up and down. It was because that roll pin was sticking halfway out, and allowing it to move.

But i'm really positive this is what it is. Hope i helped a bit
 

·
Registered
Joined
·
2,892 Posts
Discussion Starter · #19 ·
dammit, just had it towed to the dealer that i hate coincidentally...free towing...brggars can't be choosers. I will mention this to them though. THANKS FOR THE HELP!!!!!!! update to follow @ 9 am tomorrow
 
1 - 20 of 26 Posts
Top