Dodge SRT Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
177 Posts
Discussion Starter · #1 ·
Last couple of days ive been noticing a fairly quiet whine at closed throttle in gear, when i clutch, it goes away. I have a breather on the fresh air source and capped my CAI. Also capped the stock pink line. AGP block off plate on stock surge valve. TXS RFL with Perrin charge pipe.

Im not noticing any boost leaks or strange noises during acceleration or in boost...

Just curious if anyone has an idea before i get a chance to look at the car...
 

·
Registered
Joined
·
769 Posts
Wow...thats interesting. I have noticed something very similar in description. I noticed the other night when driving around looking for a parking spot. At times I would decel no gas, clutch pedal out...the lower the rpms the more noticeable the whine. lsdSRT4 do you have a rough idle or a miss at idle? I suspect my car having a TPS issue. Once off the gas into the clutch...my car will rev a few hundred rpm before coming down. Also, in gear, my decel seems slow my car even will hold rpms for a second then slowly fall. Maybe the whine is related...maybe not.
 

·
Registered
Joined
·
177 Posts
Discussion Starter · #4 ·
Other than the noise i havent noticed ANYTHING out of the ordinary...performance is the same, throttle response is the same...car is perfect except for that whine. Im worried that it may be an issue within the throttle body where the plate isnt closing completely on closed throttle but that would still show up as higher RPM's or slower deceleration and a rough idle.

Ill have to check all my caps and such in the AM...maybe im hearing a vac leak from my capped pink line (if the cap popped off)?
 

·
Registered
Joined
·
177 Posts
Discussion Starter · #5 ·
The only reason that the turbo itself should be making a noise like that is if something has damaged the impeller blades...you wouldnt really hear them making noise as the turbo winds down...however with the amount of surge i get with the TXS maybe i did break something internal...

The noise just sounds too far away...it sounds like its coming from around the throttle body/charge pipe area...and again, im not noticing any boost loss and the turbo spool sounds great...
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top