Dodge SRT Forum banner
1 - 20 of 30 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
Ok...first time post here so bear with me.
I put on stage one and a cold air intake from vertex racing the other day and the same night when I was doing a pull when I hit 5500, the car felt as though I just let off the throttle. It made some type of whining(whistling)noise and then when I lifted off the throttle and shifted to 4th ran just fine. came home checked all the lines, esp. the blue one.

Nothing disconnected...unhooked battery. Did a few more runs and ran like a beast. Then after driving around a little bit I decided to do some more hard pulls....1st cut off at 5500, 2nd 5500 and even 3rd at 5500. I dont know, I keep running the lines and checking everything. I even turned my key 3 times but no codes!!!

Now when I do a pull its shutting down at 5200. It just sounds like I let off the throttle even though I havent and when I lift and reaccelerate it happens again.

Any ideas????
 

·
Registered
Joined
·
11,943 Posts
turbo loses efficiency at that many rpms cant keep up with the volume of the engine at that speed......get a bigger turbo...
 

·
Registered
Joined
·
655 Posts
BLKDOUTSRT4 said:
turbo loses efficiency at that many rpms cant keep up with the volume of the engine at that speed......get a bigger turbo...

wrong...

thats the k&n effect buddy. your air intake has a weak elbow, and collapses at high boost, which cuts off the air flow...hence cutting off your engine. same thing happened to me. get a hard elbow from autozone, or a hard coupler from off the web and report back.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #4 · (Edited)
hate to tell you guys..no weak bends...has hard elbows....anymore answers...and to blackedout...a buddy of mine has more done to his spiking at like 26+ pounds(factory turbo) and his is runny great!


ths tho for the intel
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #6 ·
yeh stock lines....and his too...but he has a boost controller...that was aa accident when it spiked that high...he's got it under control now...but I have no idea what to do about mine...going to take it to the garage tomorrow and hook up the computer and run it a few times to see what the heck is wrong
 

·
Registered
Joined
·
275 Posts
get car dynoed you will see if it fairly stock makes no power past 5500rpm probably starts to drop off at 5200rpm try shifting the car at 5500rpm instead of trying to redline it
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #8 ·
05ACR/88shelby said:
get car dynoed you will see if it fairly stock makes no power past 5500rpm probably starts to drop off at 5200rpm try shifting the car at 5500rpm instead of trying to redline it

its not that its losing power....its as if the engine shuts off...it goes from 5200 down to 2000 as if I pushed in the clutch, but with my gas pedal floored. It just sux!!!! :flame:
 

·
Registered
Joined
·
275 Posts
chuckd83 said:
05ACR/88shelby said:
get car dynoed you will see if it fairly stock makes no power past 5500rpm probably starts to drop off at 5200rpm try shifting the car at 5500rpm instead of trying to redline it

its not that its losing power....its as if the engine shuts off...it goes from 5200 down to 2000 as if I pushed in the clutch, but with my gas pedal floored. It just sux!!!! :flame:
weird any misfires or anything?
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #10 ·
05ACR/88shelby said:
chuckd83 said:
05ACR/88shelby said:
get car dynoed you will see if it fairly stock makes no power past 5500rpm probably starts to drop off at 5200rpm try shifting the car at 5500rpm instead of trying to redline it

its not that its losing power....its as if the engine shuts off...it goes from 5200 down to 2000 as if I pushed in the clutch, but with my gas pedal floored. It just sux!!!! :flame:
weird any misfires or anything?

no nothing...now its even doing it at like 4800...just gets to that point and wham-nothing...all power gone....but im going tomorrow and having the computer hooked up to it and gonna run it some to hopefully find out whats wrong with it...should have an update by tomorrow night

thanks for your advice tho...much appreciated!
 

·
Registered
Joined
·
655 Posts
k, then youre either hitting fuel cut on the stock pcm (18.5 psi), or your plugs need to be gapped. or it could be spark blowout.
 

·
Registered
Joined
·
11,943 Posts
can a stock turbo spike 26+???? i still think its just normal for a stock turbo car....i shifted at 5500 anyways...car looses power up there anyways...
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #14 ·
BLKDOUTSRT4 said:
can a stock turbo spike 26+???? i still think its just normal for a stock turbo car....i shifted at 5500 anyways...car looses power up there anyways...

i know it loses some power, but I shift at like 5700 at the latest....but all I have done is stage 1 and CAI...it doesnt need a bigger turbo. all I know is that I will find out hopefully tomorrow what is wrong with it.
 

·
Registered
Joined
·
655 Posts
wait dude, vertex racing? from ebay? are you using the elbow that came with the package?

if so, then yes, i was right. its a weak elbow. not the bends in the piping, but the thin, weak, 90 degree rubber elbow that connects from your turbo to the air intake. Replace it with a hard one, and the problem will go away. mine started at 5200 rpms and then worked its way down to 4800. believe me, im 100 percent right. go to autozone, pick up a hard 90 degree elbow, and replace it.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #17 ·
dvoratexn said:
wait dude, vertex racing? from ebay? are you using the elbow that came with the package?

if so, then yes, i was right. its a weak elbow. not the bends in the piping, but the thin, weak, 90 degree rubber elbow that connects from your turbo to the air intake. Replace it with a hard one, and the problem will go away. mine started at 5200 rpms and then worked its way down to 4800. believe me, im 100 percent right. go to autozone, pick up a hard 90 degree elbow, and replace it.

dangit...never thought that thing would collapse, b/c there isnt enough material for it to collapse. The bend is tight, but now that I think about it with the material heating up, thats very possible...thanks man..u really helped me out!....gonna check it out in a few mins
 

·
Registered
Joined
·
655 Posts
chuckd83 said:
dvoratexn said:
wait dude, vertex racing? from ebay? are you using the elbow that came with the package?

if so, then yes, i was right. its a weak elbow. not the bends in the piping, but the thin, weak, 90 degree rubber elbow that connects from your turbo to the air intake. Replace it with a hard one, and the problem will go away. mine started at 5200 rpms and then worked its way down to 4800. believe me, im 100 percent right. go to autozone, pick up a hard 90 degree elbow, and replace it.

dangit...never thought that thing would collapse, b/c there isnt enough material for it to collapse. The bend is tight, but now that I think about it with the material heating up, thats very possible...thanks man..u really helped me out!....gonna check it out in a few mins

yeah, the reason its called the K&N effect is because the K&N typhoon air intake has the same problem. and they didnt realize it until after distributing and selling ALOT of them. but yeah, its made of weak rubber...the boost sucks so hard that it collapses like a straw. have fun with your new air intake!
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #19 ·
I will man...thanks for advice..I know in an earlier post you told me about that, but I didnt think the elbow and the freaking turbo would collapse...didnt realize it. I ordered a new elbow from advanced auto and should be in tomorrow cant wait to finally have some good pulls!!...:clap:
 

·
Registered
Joined
·
337 Posts
Noob question. What does turnin the key three times do?
 
1 - 20 of 30 Posts
Top