Dodge SRT Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1,905 Posts
Discussion Starter · #1 ·
I've noticed these things on my car since i've had it.
just wondering if you guys ran into the same problem and how best to solve it

1) When i start the car from a cold start...say overnight, i have to turn and hold the key for a second - 2 to get it to kick over. i've never had that problem in any of my other cars....do i already need new spark plugs and wires?

2) when i turn my a/c on...sometimes i hear a "turbo spool" like sound coming from either the vents or a/c unit area. it just does it for a few seconds then turns off...and repeat.
 

·
Registered
Joined
·
13,378 Posts
the "hard start" has been experienced by some. not sure about cars w/ just s0.

the on/off sound you hear when the a/c is on should be the compressor turning off & on...? just not sure about it sounding like a "turbo spool".
 

·
Registered
Joined
·
1,460 Posts
I have the same problem with the cold start after that im fine for the day. So I changed the plugs with msd wires and champions plugs it was still the same start. Do u have spring mod?? I dunno maybe if it b.c of that. :rofl:
 

·
Registered
Joined
·
904 Posts
hard starts: lots of guys have that problem. Mine went away with s2.
ac compressor: makes a brief clunk when you turn it on, is that what ur hearing?

generally these are normal for an srt, not all experience them. not to worried about them either.
 

·
Registered
Joined
·
1,460 Posts
yea ive been waiting for my s2 w/o toys for over a month now but, when it come in hopefully it cures my check engine light since i have no cat and start normal on cold engine. :thumbsup:
 

·
Registered
Joined
·
1,905 Posts
Discussion Starter · #7 ·
yeah, i believe the ac must be the compressor turning on and off.

as for the start...i don't have the spring mod. well it seems like others are having the same issues...so it must be normal. or...all our cars are crap from the factory.
 
1 - 7 of 7 Posts
Top