Dodge SRT Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey guys,
I wanna start off by saying, i am new to the neon world, mine isnt an srt but id like to make it one someday.....anyway i need some crucial help, i recently purchased an 03 1 owner neon, car has 146,××× miles on it, he stated he drove it to work, shut it off, when he started it up, it was stuck in limp mode,he said it threw a p0700 code, so he replaced speed sensor, cam sensor, fuel pump, plugs, wires, distributor, coil pack, fuel pump, the transmission fluid and filter, and im not sure what else, but it was still stuck in limp mode, so he parked it, it sat for 3 yrs, and myself, thinking it was probably something simple, accquired it for 200$, pulled it home and discovered the intercooler in the radiator had busted, filling the tranny with water, i replaced the rad, the fan, the filter, flushed the tranny, added new fluid, put a fresh battery in, and fired up,it ran like a dream, pulled it into D, at 30mph the engine light came on, still stuck, ok, researched online, fixed a couple broken ground wires from freeze out plugs to the shock mounts replaced engine mounts, replaced the Tcm, both speed sensors,refushed, new tranny filter fluid n gasket, newTps, still in limp mode....only throws that 0700 code, checked my fluids there both not mixing together, but car is killing me, inspected the harness, cleaned all the points and snapped it together bolted it down, my tranny fluid is still got a white color but its more red now, checked my codes earlier and i had a 0700 0365 and 0344.. any help would be appreciated the car pulls great in reverse and 2nd but i cant run 35 everwhere and i hate tospend more $$ ive got over 600 in it now . Feel free to pick my brain, im all ears
 

·
Premium Member
Joined
·
4,357 Posts
Hey guys,
I wanna start off by saying, i am new to the neon world, mine isnt an srt but id like to make it one someday.....anyway i need some crucial help, i recently purchased an 03 1 owner neon, car has 146,××× miles on it, he stated he drove it to work, shut it off, when he started it up, it was stuck in limp mode,he said it threw a p0700 code, so he replaced speed sensor, cam sensor, fuel pump, plugs, wires, distributor, coil pack, fuel pump, the transmission fluid and filter, and im not sure what else, but it was still stuck in limp mode, so he parked it, it sat for 3 yrs, and myself, thinking it was probably something simple, accquired it for 200$, pulled it home and discovered the intercooler in the radiator had busted, filling the tranny with water, i replaced the rad, the fan, the filter, flushed the tranny, added new fluid, put a fresh battery in, and fired up,it ran like a dream, pulled it into D, at 30mph the engine light came on, still stuck, ok, researched online, fixed a couple broken ground wires from freeze out plugs to the shock mounts replaced engine mounts, replaced the Tcm, both speed sensors,refushed, new tranny filter fluid n gasket, newTps, still in limp mode....only throws that 0700 code, checked my fluids there both not mixing together, but car is killing me, inspected the harness, cleaned all the points and snapped it together bolted it down, my tranny fluid is still got a white color but its more red now, checked my codes earlier and i had a 0700 0365 and 0344.. any help would be appreciated the car pulls great in reverse and 2nd but i cant run 35 everwhere and i hate tospend more $$ ive got over 600 in it now . Feel free to pick my brain, im all ears
First off, welcome to the site.

You already know this is a site aimed more at the SRT variant of these cars, so the knowledge base for your model is going to be a bit more limited. While i realize they are basically the same car, there are differences (i.e. the automatic transmission).

by "limp mode," what exactly do you mean? Car wont go above a certain rpm? car wont go above a certain speed? car wont shift gears? etc...

here are a couple of threads i found real quick which may have info that helps...

 

·
Registered
Joined
·
771 Posts
I would definitely post these questions on neons.org if I were you. You're much more likely to get the appropriate responses on that board.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
First off, welcome to the site.

You already know this is a site aimed more at the SRT variant of these cars, so the knowledge base for your model is going to be a bit more limited. While i realize they are basically the same car, there are differences (i.e. the automatic transmission).

by "limp mode," what exactly do you mean? Car wont go above a certain rpm? car wont go above a certain speed? car wont shift gears? etc...

here are a couple of threads i found real quick which may have info that helps...

i read everything in neons.org. it goes into r and d but its like its stuck in 2nd , at 55mph its reving really high, and taking off it has no power, i just figured u guys tear into neons everyday, thanx
 

·
Registered
Joined
·
428 Posts
i read everything in neons.org. it goes into r and d but its like its stuck in 2nd , at 55mph its reving really high, and taking off it has no power, i just figured u guys tear into neons everyday, thanx
Grab a factory service manual and take that trans apart. Automatics don't like water, it causes real internal damage.

You might wanna find another neon to swap transmissions with, or find an SRT to body swap with. Thats a tough call to make, but unloading the parts cannon just gets expensive buddy.

Sent from my SM-G988U using Tapatalk
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Grab a factory service manual and take that trans apart. Automatics don't like water, it causes real internal damage.

You might wanna find another neon to swap transmissions with, or find an SRT to body swap with. Thats a tough call to make, but unloading the parts cannon just gets expensive buddy.

Sent from my SM-G988U using Tapatalk
ty man l thought about rebuilding it....maybe ls1swap on an s10 frame lol
 
1 - 7 of 7 Posts
Top