Dodge SRT Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
13,378 Posts
Discussion Starter #1 (Edited)
i dont have my car with me.

just want to verify if the item circled is the camshaft position sensor 1-05093508AA.

i have P0340 and intend to replace the CPS later today.

thanks

-ayat108

 

·
Registered
Joined
·
7,310 Posts
Yes. Have you checked to make sure the wiring and connector haven't been damaged yet?
 

·
Registered
Joined
·
13,378 Posts
Discussion Starter #3
thanks for verifying. i have not checked the wiring yet since i wasnt sure where it is. but will this afternoon when i pickup the car from getting its brakes done. as an aside, the magnet is on backorder.
 

·
Registered
Joined
·
13,378 Posts
Discussion Starter #4
the wires looked fine up to the connector. the harness was still intact. PCM wires/connect appeared ok. swapped the CPS in 3hrs (it's really a 10min job), and took the car for a spin. test ok.

if i can make 1 or 2 gas-tanks w/o P0340 CEL then i will have verified that it's not the sensor. (battery & fuse disco could have cleared the CEL).if i still get CEL either the harness wires, pcm, or magnet is jacked up.

thx for the assist.
 

·
Registered
Joined
·
13,378 Posts
Discussion Starter #5
replaced sensor, was sure to clear magnet surface of any dust/grit from removal. was sure to use the new green band/seal. torqued about the same, sure not to overtighten. car looks to be on it's way to less than 1/4 tank and no problems.
 
1 - 5 of 5 Posts
Top