Dodge SRT Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
422 Posts
Discussion Starter · #1 ·
I am trying to tune my profec b. If i turn it off i pull 15 psi with no problem. If i turn it on and i go over 16 to 20 psi it keeps bouncing off the high boost kinda like im hitting a rev limiter. it doesnt matter if i run 0 gain or 25 gain it will stiil do the samething. I tried turning the vac lines on the bc around but that made the bc not control at all. so i was thinking that i might be pulling timing? am i right?
 

·
Premium Member
Joined
·
9,774 Posts
Rickelus4 said:
I am trying to tune my profec b. If i turn it off i pull 15 psi with no problem. If i turn it on and i go over 16 to 20 psi it keeps bouncing off the high boost kinda like im hitting a rev limiter. it doesnt matter if i run 0 gain or 25 gain it will stiil do the samething. I tried turning the vac lines on the bc around but that made the bc not control at all. so i was thinking that i might be pulling timing? am i right?
do you have the boost limiter set on the EBC, usually this is the cause with EBC's.

make sure the boost limiter is not set to "0".
 

·
Registered
Joined
·
422 Posts
Discussion Starter · #3 ·
right now my max boost is set at 16psi. and the limiter is set at 5% i am hitting 18.5 psi. do i need to raise my limiter setting?
 

·
Registered
Joined
·
422 Posts
Discussion Starter · #5 ·
Exhaust Depot said:
vacuum lines are routed wrong.
on my first test drive i hit 20 psi, then went to 19, dropped to 17, and now im back up to 18 psi. Would i still be able to change boost if the vac was setup wrong?

have the valve set up via the how to agp install set up, and that is working(kinda) when i set it up the way the greddy hand book illustartes i cant change anything. so i belive the bc solenoid is right. what im not sure about is if my wga lines are backwords. i have an external wg and im not sure what the top and bottom of the "Can" is. if that is set backwords would that be whats causing the problem?

Thank guys.
 
1 - 5 of 5 Posts
Top