Dodge SRT Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
2,135 Posts
Discussion Starter · #1 ·
ok i just installed dw st 2 680 injectors, the process i used was to clen around the stock injectors while they were still in palce then i took out fuel relay and tried to crank until car wouldnt start to fget rid of fuel pressure then i swapped and put back together and it runs fine just a little odd when idleing cause the computer has to learn the bigger injectors


but now i have a new cel p 0627 fuel pump relay
but we installed right and the car runs and pushes fuel fine but it wont go away how do i get rid of it???
 

·
Registered
Joined
·
5,965 Posts
uncutfourplay said:
ok i just installed dw st 2 680 injectors, the process i used was to clen around the stock injectors while they were still in palce then i took out fuel relay and tried to crank until car wouldnt start to fget rid of fuel pressure then i swapped and put back together and it runs fine just a little odd when idleing cause the computer has to learn the bigger injectors


but now i have a new cel p 0627 fuel pump relay
but we installed right and the car runs and pushes fuel fine but it wont go away how do i get rid of it???
Just take off the batt. and the code will go away:hi: You more than likely left the battery connected after cranking
 

·
Registered
Joined
·
2,135 Posts
Discussion Starter · #3 ·
yep sure did lol but i pulled the fuse that everyone pulls to reset the pcm the one with that big yellow handle thing on it and that didnt take care of it either.... but ill try the batt thing
 

·
Registered
Joined
·
943 Posts
uncutfourplay said:
yep sure did lol but i pulled the fuse that everyone pulls to reset the pcm the one with that big yellow handle thing on it and that didnt take care of it either.... but ill try the batt thing
I have a 05 but I dont think your pulling the right fuse the one with the yellow handle thing on mine is ,I think is the radio you might want to check that?
 

·
Registered
Joined
·
2,135 Posts
Discussion Starter · #5 ·
i pulles the one with the yellow grip thingy and it cut power to everything neone have suggestions??
 

·
Registered
Joined
·
3,386 Posts
if you are looking from the drivers side you need to pull the 20a fuse on the left side that is in the 2nd slot away from you. The fuse with the yellow piece on it cuts power to the interior (lights, radio etc so that the battery does not die when the doors are open at the dealership in the showroom.
 

·
Registered
Joined
·
2,135 Posts
Discussion Starter · #7 ·
oh i see im dumb lol ok will do lol
thanks:thumbsup:
 
1 - 7 of 7 Posts
Top