Dodge SRT Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Just got the car and 4th to 3rd gear downshift is grinding won't properly engage unless rev matched. 1 - 5 upshifts and 5 -4 downshift 3-2-1 downshift seem fine.

I took it to two transmission shops who test drove the car and both confirmed 3rd gear engagement issue. Surprisingly one shop thought it might not be synchros but a clutch issue. One mechanic commented that the clutch seemed stiff and not as springy as he'd expect. Even though it doesn't grind he also thought first gear seemed hesitant.

Clutch via inspection hole appears to be riveted modular. Shift cables were recently replaced by previous owner at Dodge dealership. Crossover and clutch height all properly adjusted. Can a worn clutch fork cause an issue with only 4/3 downshift?

I also read that a way to check synchros is to idle the car and with your foot off of the clutch pedal try putting it into each gear. The idea is if synchros are good the gears will be locked out and if synchros are bad it will start to grind going into that gear. Tried this and confirmed no grinding and locked out on every gear.
 

·
Registered
Joined
·
2 Posts
I’m having same issue with rev match keeping it from grinding, mine also has problem going into first before rpms drop at idle speed
 

·
Premium Member
Joined
·
4,153 Posts
If it were a clutch/clutch fork issues (which would be a clutch disengagement issue), the problems would usually be more prevalent on the lowest gears (1/2/R). Your problem is most likely the syncro or the shift fork, or a combination of both. Both are common issues with our transmissions.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
If it were a clutch/clutch fork issues (which would be a clutch disengagement issue), the problems would usually be more prevalent on the lowest gears (1/2/R). Your problem is most likely the syncro or the shift fork, or a combination of both. Both are common issues with our transmissions.
The gear set is apart and the problem was a flat spot on the third gear blocker plate (synchro ring). Fourth gear blocker plate was good but both are being replaced with Werks Racing synchro rings and I'm upgrading the springs.
 
1 - 4 of 4 Posts
Top