Dodge SRT Forum banner
1 - 16 of 16 Posts

·
Premium Member
Joined
·
1,294 Posts
Discussion Starter · #1 ·
An in-car vid I shot sunday at the track.

This shows what happens with stock motor mounts, and too hard a launch !!

(Warning, this vid is about 30megs, and you may have to save it to view)

http://home.tampabay.rr.com/blackcat/NOT.wmv
 

·
Banned
Joined
·
27,026 Posts
i'll host it on h8r if it downloads :roll:
 

·
Banned
Joined
·
27,026 Posts
he ran a 14.0 at 100mph last time we were out at BMP but i'll let him tell you bout the runs yesterday :lol:
 

·
Banned
Joined
·
27,026 Posts
that was my friend Jared in the 5.0 Coupe that pass right there was his best yet 13.17 at 103mph.....yeah i'll second that but instead i'll say got mounts?
 

·
Banned
Joined
·
2,905 Posts
ouch

ouch ouch ouch...reminds me of the back end of an S10 pickup LOL LOL LOL

I can see why people upgade motor mounts rather fast in these. what was the rpm you launched at??
 

·
Registered
Joined
·
1,826 Posts
that looks painful just watching it :shock:
 

·
Registered
Joined
·
537 Posts
DAMN! :shock:
that is what I am hoping not to do with 16 pounds of boost on saturday. I have the launch pretty good with stock boost, but I am going to practice at emtpy stoplights on friday just to see how hard it is with higher than stock boost.
 

·
Premium Member
Joined
·
3,671 Posts
Thats why I just ordered a Duel stage boost controller, so I can dial in boost needed for first gear and after I shift to second I can switch to max boost for the rest.

Dude take it easy on the launches, I launch at about 2000 RPM and gently make it though first and in second let her have it. Best time is 14.06 @ 102.5 mph.
 

·
Registered
Joined
·
537 Posts
I must admit I did do that in front of the house the first time I decided to get on it from a stop. It scared the crap out of me! I stopped to make sure everything was ok before driving off. :oops:
 

·
Premium Member
Joined
·
1,294 Posts
Discussion Starter · #16 ·
ACR2NV, it's already posted on h8rs. I was having trouble getting it to link, so I threw it on my site.

BTW, even with the wheel hop, I got a 2.161 60' time, and 14.333 for the 1/4... :oops: Launch was at about 2800

daytonagts, I've got a 14.001 @ 100.07 from last time, so I was trying different tire pressures, and launch rpm's.

Best run yesterday was 14.236 @ 98.21. It was too damn hot, and crowded.
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top