Dodge SRT Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I'd like to start by saying i have looked all over for my specific problem and haven't found any threads about it. So, my horn doesn't work right, it works when i hit the panic button and lock my car and it will also work when i press the wheel, but only if i grab the bottom of the steering wheel and pull up on it. Once i let go of the wheel it quits working and only works when i push or pull the wheel up and put tension on the column. Anybody have any ideas where to start. any help would be appreciated
 

·
Registered
Joined
·
2,198 Posts
I'd like to start by saying i have looked all over for my specific problem and haven't found any threads about it. So, my horn doesn't work right, it works when i hit the panic button and lock my car and it will also work when i press the wheel, but only if i grab the bottom of the steering wheel and pull up on it. Once i let go of the wheel it quits working and only works when i push or pull the wheel up and put tension on the column. Anybody have any ideas where to start. any help would be appreciated
Pull the airbag and check the horn circuit through the clock spring. They break over time. If i were you id find one in a JY cause new ones were somewhere between you can be serious and id have to sell my home.

Sent from my SM-G988U using Tapatalk
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top