Dodge SRT Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
358 Posts
Discussion Starter #1
I had my stage 2 installed at the dealer about 2 months ago, today for the first time since it was finally nice out i bought 5 gallons of racegas and mixed it in with 3.5 gallons of 93. Now i pushed the HOM button and the led didn't light up. The car really didn't seem to pull much harder and I'm wondering is is possible that HOM is hooked up, or is just the led not hooked up, any feedback would help.

thanks
chris
 

·
Registered
Joined
·
268 Posts
You have to hold the button until the led lights up. You will notice a difference! The led should be lightly lit all the time if installed correctly. It is very bright once engaged. Even if the led is not installed right I think if you start your car and then hold the hom button for about two seconds it should be enabled.
 

·
Registered
Joined
·
672 Posts
nathanstl said:
You have to hold the button until the led lights up. You will notice a difference! The led should be lightly lit all the time if installed correctly. It is very bright once engaged. Even if the led is not installed right I think if you start your car and then hold the hom button for about two seconds it should be enabled.
As stated above. If it isn't lighting up dimly at start-up all the time, the leads running to the back of the LED are switched.
 

·
Registered
Joined
·
16,766 Posts
highrolla8185 said:
I had my stage 2 installed at the dealer about 2 months ago, today for the first time since it was finally nice out i bought 5 gallons of racegas and mixed it in with 3.5 gallons of 93. Now i pushed the HOM button and the led didn't light up. The car really didn't seem to pull much harder and I'm wondering is is possible that HOM is hooked up, or is just the led not hooked up, any feedback would help.

thanks
chris
you should just be able to push it and the RED LED should come on. You will notice a big difference in performance with it engaged, if you dont, take it back and have them check through their wiring job. You paid a good amount to have them install it, so it should be PERFECT........
 

·
Registered
Joined
·
394 Posts
i tried my HOM last week with 100 octane sunoco race gas and some 104+ the LED lit right up and it felt a little more powerful but it didn't feel like an extra 15 or 20.
smelled good though coming out the back!
 

·
Registered
Joined
·
731 Posts
same thing happened to me. the two wires on the back of the red LED just need to be reversed. takes 3.5 seconds.
 
1 - 6 of 6 Posts
Top