Dodge SRT Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have a 2003 SRT4. The cars not stock. I didnt do these upgrades I bought it 2 months ago and no issues until 4 days ago. The car keeps jerking when accel. The car idles like complete shit. it shuts off at idle if
I dont push the gas. My A/F ratio is super lean. fuel pressure at idle is 60psi. The car spits and sputts when driving. I can rev it in N and have no issues. But driving the only time I can slightly get it to drive is WOT. It doesnt spit and hesitate as much on WOT. I've changed MAP, TPS, Crank Sensor, Coil, Wires, Plugs. I dont have a o2 senor and havent since Ive had the car two months and it hasnt been an issue. It was driving good the night before. the morning I started it and drove it the car started doing this. I'm lost and want to blow it up at this point.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
There no no codes except multiple misfire. Wot I get my 10psi of boost. Which is what it’s set to but only at WOT.
 

·
Premium Member
Joined
·
3,453 Posts
I'm almost 100% certain your intake manifold gasket how blown out. Very easy fix. Should show as an issue if you take hybridkid's advice of doing a boost/vacuum leak test.

if this is the case, take extra extra care when bolting the intake maniflold back down as they are known to crack if too much force is put on the bolts.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
I still can't find out what's going on with this car. Did a leak test and held good underpressure. I'm beside myself at this point!
 
1 - 8 of 8 Posts
Top