Dodge SRT Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
367 Posts
Discussion Starter #1
so the other day i read a post about taking the CEL off your car by unplugging your battery negative and unplugging a fuse for about 10 sec. well i did so and then my car worked a little bit, i got to drive it around and then i parked and came back to the car 30 minutes later to go out for the night and the car turned on for about 3 sec. and then i turned the ac on and the car turned off.

now i have this red dot on my dash and the car wont even turn over.

i need help especially because now i got the srt4 towed to the dch temecula dealership and asked them to reprogram my key to match the car since the red light is on and that means the skim is wrong.... well now they tell me their comp cant even read my ecu on my car for some reason and need to charge me a $90 dollar diagnosis fee and thats just to start off in.

i probably shouldnt have unplugged the fuse or battery and just went the OBDII sensor way but i was lazy and now im in this hardship because now my car doesnt work.....

is there any help or advice someone can give me.

my key is grey key and i bought this car from a private seller

its a 2004 srt4

any help would be appreciated.... just kind of pissed cause the car was working fine.

btw the check engine codes i got before i did this, that turned me onto doing this was 0032 and 0038 and 1187

which have to do with o2 sensors and then low oil temp i think or something like that

im located in temecula

please help
 

·
Registered
Joined
·
561 Posts
Same exact thing happened to me and what happened is the PCM wasn't getting power. Check the fuse going to the PCM if it has power then check at the PCM. If there isn't voltage there then you'll have to find the break in the wire from the fuse to PCM. If it does have voltage then I don't know what to do.
 

·
Registered
Joined
·
878 Posts
Ur problem was not disconnecting the battery before unpluggin the pcm. The pcm locked itself.. The car thought it was being stolen.. Im pretty sure u can go to the dealer for that issue..

If im correct.. the car wont turn over and the red light is blinking?


Sent at WOT from my autoguide iphone app
 

·
Registered
Joined
·
274 Posts
That red dot turns on when you are in the middle of flashing a new tune with the DSP, I always wondered what it meant
The red dot is your alarm (sentry). It blinks when you lock your car after you get out.
 

·
Registered
Joined
·
367 Posts
Discussion Starter #7
hmmm thank you all! it was all valid what you all said....

the culprit was a little 20 amp fuse that blew.... seriously

swapped it out and now my car works beautifully

thanks guys for the quick reply too

the red dot blinked for a little bit when the car was in the on position and then it stayed on the dash but when i took the key out the red dot left but it didn't turn over until the fuse was replaced


btw the dealership did not charge my dad a penny cause he sort of raised hell there since he is a 1st generation filipino and hard to understand his english, it sort of works out because then the higher ups really wanted to make him happy lol, plus cause he's old.
 

·
Registered
Joined
·
742 Posts
There you go.. Next time you every run into that issue you know there's no power going to the PCM.. just need to find out what's causing it. good find tho.
 

·
Registered
Joined
·
7,310 Posts
Lucky, as DCH doesn't have the best service reputation (from personally experience with friend and family and if you look at the reviews). They've supposedly got a new general manager sometime this year but after seeing friends get royally burned by them I'd tow my Dodge to something like a random Hyundai or Toyota dealer before I let DCH touch my car.

What you're describing is likely the ASD fuse that powers the computer, ASD (auto shutdown) relay and the fuel pump relay (#21 in the underhood power distribution box if I recall correctly off memory). If you had a trouble code you were trying to clear after performing a repair and you wanted to reset the computer you didn't have to pull a fuse and the battery cable, instead all you needed to have done was remove the negative battery cable or the ASD fuse for ~30-60 seconds.

It wasn't responsible for the issue in your case, but another somewhat common issue (especially on cars where the harness was modified for the Mopar Stage 2 or Stage 3 "with toys" kits) is for the plugs that go into the computer to work loose and can cause communication errors between the computer and SKIS (Sentry Key Immobilizer System) and more likely no-start or severe drivability issues.
 

·
Registered
Joined
·
367 Posts
Discussion Starter #10
thanks blackbird, are you able to check out my car, my friend thats a mechanic told me i also have an electrical problem (for a totally different situation, not the red dot anymore since it is fixed now) well the new problem is that when i turn on my ac the car will do the same red dot problem so i guess what im saying is that there might be a messed up ground because the ac shouldnt do this right? i havent tried to look since its been so freaking hot when i get off work, but yea this sucks cause my car isnt 100%
 

·
Registered
Joined
·
7,310 Posts
I've been super busy with work and just catching up some sleep but that might be a possibility later this week. I'll see if I can remember to clear out a couple messages from my inbox tomorrow and shoot you my email address.
 

·
Registered
Joined
·
367 Posts
Discussion Starter #12
Hey blackbird so my car is not getting any boost anymore, Do you have time next week so we can look under the hood of each of our cars and maybe see the problem
 

·
Registered
Joined
·
7,310 Posts
Clearing out enough PMs to send you a message right now with my email address. I should be around most of the weekend.
 

·
Registered
Joined
·
2 Posts
hmmm thank you all! it was all valid what you all said....

the culprit was a little 20 amp fuse that blew.... seriously

swapped it out and now my car works beautifully

thanks guys for the quick reply too

the red dot blinked for a little bit when the car was in the on position and then it stayed on the dash but when i took the key out the red dot left but it didn't turn over until the fuse was replaced


btw the dealership did not charge my dad a penny cause he sort of raised hell there since he is a 1st generation filipino and hard to understand his english, it sort of works out because then the higher ups really wanted to make him happy lol, plus cause he's old.
May u tell me what fuse it was I’m haveing the same issue thanks
 

·
Premium Member
Joined
·
4,248 Posts
May u tell me what fuse it was I’m haveing the same issue thanks
there really arent very many fuses. one box of them under the hood, and one behind the panel on the dash you can see when the drivers door is open.
 
1 - 16 of 16 Posts
Top