Dodge SRT Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
125 Posts
Discussion Starter #1
I have had my srt-4 for around a year now and I have had no problems until today. When I started my car up the check engine light along with all of the other lights came on and then disappeared. Well, a couple of seconds later the check engine light came on and stayed on. It is lit up solid btw, not flashing. I checked the manual and it said it could possibly be a loose gas cap or bad gasoline. I checked the gas cap and the oil but everything seems fine. I am wondering if it is the tps problem that alot seem to have. Please help me somone. Thanks
 

·
Registered
Joined
·
1,028 Posts
what are your codes....
 

·
Registered
Joined
·
8,246 Posts
Check the codes.


put key in the ignition,
turn key to "on" position, turn key to "off" position, turn key to "on" position, turn to "off" position, then turn to "on" position and leave key in "on" position. You should get a code where your mileage reads.
 

·
Registered
Joined
·
1,028 Posts
ENapa said:
Check the codes.


put key in the ignition,
turn key to "on" position, turn key to "off" position, turn key to "on" position, turn to "off" position, then turn to "on" position and leave key in "on" position. You should get a code where your mileage reads.
sorry bout that. i should have explained myself alittle better. do what Napa tells you and then let us know. BTW do you have a catless exhaust???
 

·
Registered
Joined
·
1,028 Posts
P0456-evap System Small Leak
 

·
Registered
Joined
·
8,246 Posts
EVAP System small leak. I would take it to the dealer.
 

·
Registered
Joined
·
8,246 Posts
It is not a major deal though so don't get scared.
 

·
Registered
Joined
·
73 Posts
Could it be the old gas cap being too tight code?

I know on my 00' dakota, I got a CEL, and it turned out to be the gas cap was on funky. I put it in correctly and it went away in a day or so.


Just my $.02


Jon
 

·
Super Moderator
Joined
·
34,544 Posts
i think our gas cap only tightens so much if i remember correctly(i drive 3 cars regularly so i might be thinking of one of the others)
 

·
Registered
Joined
·
72 Posts
Yeah id check the gas cap for cracks jus make shure its tight and reset the pcm of that doesnt solve check the evap lines for small cracks or 1 could have came off 2 no big deal
 

·
Administrator
Joined
·
39,215 Posts
take off gas cap, reseat it and turn it, let it click 2 or 3 times. drive the car a little bit, turning it off and back on a few times. See if the code stays or goes away. You could reset the pcm but that is up to you (remove fuse #21 under the hood, yellow 20 amp toward the fender in the left of the two columns of fuses).
 

·
Registered
Joined
·
1,871 Posts
that code also happens if you top off your gas everytime you fill up. Never top off your gas or it can be something as simple as your gas cap.
 
1 - 15 of 15 Posts
Top