Dodge SRT Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
842 Posts
Discussion Starter · #1 ·
well i got the excel dl-46 and the rear fit perfect but when I was driving I knew something was rubbing because the wheel was shaking so I turned around and took it back to the tire place. The guy took the car back on the lift and said you can bairly see but the wheel rubs ever so slightley against the hub. I called wheel max they said a 5mm spacer should solve the problem. I just want to know the other forum members who have the wheel have this problem?? Anyone in Daytona know where I can get spacers from because here in Palm Coast they don't even know what the hell they are!

Thanks in advance,

Lou

Heres a pic if of the wheels

 

·
Registered
Joined
·
3,707 Posts
I have the DL-46 in 18"x7.5".
What size are yours? Are you sure it's not rubbing against the strut? I have coilovers which I think give you more clearance.

That sucks, but spacers should fix it.
 

·
Forum Moderator
Joined
·
13,324 Posts
htx said:
well i got the excel dl-46 and the rear fit perfect but when I was driving I knew something was rubbing because the wheel was shaking so I turned around and took it back to the tire place. The guy took the car back on the lift and said you can bairly see but the wheel rubs ever so slightley against the hub. I called wheel max they said a 5mm spacer should solve the problem. I just want to know the other forum members who have the wheel have this problem?? Anyone in Daytona know where I can get spacers from because here in Palm Coast they don't even know what the hell they are!

Thanks in advance,

Lou
umm...what? Rubbing against the hub? That doesn't make sense since the wheel MOUNTS to the hub.

You sure they didn't say caliper or strut? Do you hear grinding when you drive or do you just feel vibration?
 

·
Registered
Joined
·
842 Posts
Discussion Starter · #8 · (Edited)
no they said hub but I fixed it I took the stock rings off. There was 2 on each side in the front so it threw the way the wheel was on the hub like the top was touching and the bottom wasnt(because that stupid ring was there) so when I drove it would shake. I don't think it was rubbing anyway they are just stupid. It was a simple fix I should have done it myself in the first place, but I was in a hurry because I was supose to work but then they called and said I didnt have to work. You pay when you try to take the easy way out.
 

·
Registered
Joined
·
842 Posts
Discussion Starter · #9 ·
Wheat_Burner said:
I have the DL-46 in 18"x7.5".
What size are yours? Are you sure it's not rubbing against the strut? I have coilovers which I think give you more clearance.

They are 17's
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top