Dodge SRT Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
700 Posts
Discussion Starter #1
my car is acting up really bad.. When i am wot around 5600 it dies out . it kind of flat lines.. wat could this be ?
 

·
Banned
Joined
·
6,529 Posts
im not clear clear on to what you have on your car and what is not on the car......please explain alittle more
 

·
Registered
Joined
·
700 Posts
Discussion Starter #3
i have every thing that is on my sig. Its hard to explain. Im not sure wat is going on with it. It just feels like it just flat lines towards teh end of the rpms. my car feels like its in nuetral when it does it. it weird. I was thinking it was something to do with my coil pack or wires .. or maybe even my plugs. i have had my car for about a year and haveent changes the plugs. and i have raced a good amount
 

·
Banned
Joined
·
6,529 Posts
ok first thinks to check....plug gap.....i would prob take your plugs down to about 40 with 17#...........second thing.....make sure nothing is vibrating to make and vibrations in the motor and make knock.......thirdly.....make sure you dont have a boost leak anywhere.....that might be a prob
 

·
Banned
Joined
·
6,529 Posts
like if the exhaust is ratteling on something or if there is something loose under the hood and its banging against the block it will take that as knock and reduce timing
 

·
Registered
Joined
·
700 Posts
Discussion Starter #8
I took out the plugs and the bottom were very white .. I gaped them at 40. You thing its becuase I have been running to much boost for to long with out any fuel upgrades ?
 

·
Registered
Joined
·
296 Posts
change the wires
 

·
Banned
Joined
·
6,529 Posts
17-18 is max on the stock fuel system.....i have seen plenty of cars that have fmic...tbe...3" intake...18# wastegate....and hard pipes put them right at the 12 mark for afr's....stage 1 would be alittle safer running those boost levels....there will be white on the tips but there should be black up the plug
 

·
Registered
Joined
·
700 Posts
Discussion Starter #11
They are black up the plug. It doesn't do it when I lower the boost drastically. It seems to mess up when I run 16 17 spike
 

·
Registered
Joined
·
12,239 Posts
ptperformance said:
I can not belive it took 11 posts to get to that. Yes it is fuel cut, get a clamp and PTP FPR mod to keep things happy with your AFR's.

these are good mods but i cant see a 05 spiking 17 and holding 14-15 fuel cutting.....i would say possibly the k&N sucking closed or boost leak PM me if you need help with a leak test. also overboost fuel cut seems to like to hit around 4000rpms
 

·
Registered
Joined
·
296 Posts
that fact that hes been running this setup for awhile makes me think its not fuel cut...
i've been running 18 spike 15hold with no clamp for the past month on my 05..my guess is still on the plugs and wires
 

·
Banned
Joined
·
6,529 Posts
yeah there is no way an 05 with that little boost is hitting fuel cut.....i ran 19 on mine no clamp or anything and it didnt and i have an 05
 
1 - 17 of 17 Posts
Top