Dodge SRT Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
1,038 Posts
Discussion Starter #1
here's what it does. When I turn the key, all I get is a loud clicking. no fire or codes or anything. all the electrical comes on but not the engine. I need help quick. Car ran just fine about ten minutes ago.
 

·
Registered
Joined
·
1,038 Posts
Discussion Starter #3
checked it. no change. the fuse is good and ohms out to .2. I think the tone of the click has gotten deeper though.
 

·
Registered
Joined
·
1,038 Posts
Discussion Starter #5
How can you test that out?
 

·
SRTforums Veteran
Joined
·
9,870 Posts
Can you hear the starter? Can you hear the fuel pump if you turn the key to the last click?

Try having someone mildy bang the starter when you turn it over
 

·
Registered
Joined
·
1,038 Posts
Discussion Starter #8
It's not the battery. 12.37 VDC. It's not plugs or wires. where is the stater located? and have then just hit it with a screwdriver?
 

·
Registered
Joined
·
1,038 Posts
Discussion Starter #10
all I hear is a loud clicking. kinda like the final buzzer at a basketball game.
 

·
Registered
Joined
·
1,666 Posts
Speicker said:
It's not the battery. 12.37 VDC. It's not plugs or wires. where is the stater located? and have then just hit it with a screwdriver?
voltage means nothing, its amperage u need, 8 AA battery make 12 volts but will they start ur car?
 

·
Registered
Joined
·
1,038 Posts
Discussion Starter #12
How many amps do I need? I am not sure how to check it on this multimeter. but it said .001
 

·
Registered
Joined
·
2,955 Posts
i dunno - my starter went and made a little clicking. battery does sound like a better possibility
 

·
Registered
Joined
·
1,666 Posts
Speicker said:
How many amps do I need? I am not sure how to check it on this multimeter. but it said .001
most multimeters dont check amperage, easiest thing to try is, hook the meter up test as voltage, crank the car and watch the voltage drop.
 

·
Registered
Joined
·
671 Posts
try jumpstarting it. You could have a dead cell in the battery which would make all the electrical things in the car still work, but it wont have enough power to crank the motor.
 

·
Registered
Joined
·
1,038 Posts
Discussion Starter #16
most multimeters dont check amperage, easiest thing to try is, hook the meter up test as voltage, crank the car and watch the voltage drop
Alright, very weird. I went out and tried it and nothing happened. Then I connected the miltimeter between the pos and neg of the battery and it started right up!!! i have no idea why? any suggestions? i'm letting it run for a minute before I try again.
 

·
Registered
Joined
·
2,205 Posts
I say dead battery . All u here is ticking noises. Yup its ur battery. Jump start it for like 2 seconds and bamm ,it'll turn on. Trust me bought a new battery at wlamart for 40 bucks with 540 cranking amps and fixed the problem. Had the car over 2 yrs now and first battery.
 

·
Registered
Joined
·
1,666 Posts
Speicker said:
Alright, very weird. I went out and tried it and nothing happened. Then I connected the miltimeter between the pos and neg of the battery and it started right up!!! i have no idea why? any suggestions? i'm letting it run for a minute before I try again.
more than likely a dead cell then, it will randomly happen, just replace it for 40-50 bux.
 

·
Registered
Joined
·
1,038 Posts
Discussion Starter #19
Just tried it again, and same thing. No start regularly but as soon as I connect the posts with the mulitimeter, it starts right up!
 

·
Registered
Joined
·
296 Posts
sounds like a bad cell in the battery
 
1 - 20 of 21 Posts
Top