Dodge SRT Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
ok, i know u guys have probly answered this ? acabagillion times but i need help. I jus got a APG billot WGA and i have a MBC but its not hooked up. K heres the deal...i adjusted the wastegate so that it boosts like 18psi but it takes FOREVER!!..its slow as hell untill like 4500RPMs..i hope its not supposed to be like that..i have the vaccum lines hooked up the way it would be stock..i would like it if someone could help with a step by step on how to tune this thing right..also i got a check engine light ..is there anything that can be done about that?
 

·
Registered
Joined
·
741 Posts
Ebud316 said:
ok, i know u guys have probly answered this ? acabagillion times but i need help. I jus got a APG billot WGA and i have a MBC but its not hooked up. K heres the deal...i adjusted the wastegate so that it boosts like 18psi but it takes FOREVER!!..its slow as hell untill like 4500RPMs..i hope its not supposed to be like that..i have the vaccum lines hooked up the way it would be stock..i would like it if someone could help with a step by step on how to tune this thing right..also i got a check engine light ..is there anything that can be done about that?
18psi on a stock ecu = :gay: . Drop the boost to 16 or get Stage 1. 18psi is too high for the stock computer.

Percy
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top