Dodge SRT Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
402 Posts
Discussion Starter #1 (Edited)
I don't have a pic, but I'm able to tighten the traction bar so much that it really pulls on the bolt that holds the bushings on. the bolt sits bent at about a 30-40 degree angle towards the front of the car when the bars are fully hand tightened.

I also still get wheelhop at the top of 1st gear as well. car has turboback, stage1 and wga so it's not like it's making tons of power. I have prothane race inserts in both torque struts as well.

any suggestions?
 

·
Registered
Joined
·
164 Posts
Get solid mounts, I had a little wheel hop with just the h-brace and traction bars. THe H-Brace and traction bars cut down wheel hop alot but after I put the soild mounts on the car I had no wheel hop at all just burnt rubber lol.
 

·
Registered
Joined
·
842 Posts
RyanC said:
bump for answer on the bolt angling 40 degrees towards the front of the car...normal??
That does not sound normal. Mine are straight. Call the shop and talk to Mike, I know they are very busy and may not be on here as much as they used to be. Mike and Gregg are there full time and I am sure they can get you straightened out.
 

·
Registered
Joined
·
1,200 Posts
any updates on this? my bolts are bent forward as well...

I have a JLM solid tranny mount, bwoody motormounts, and bwoody hbrace/tractionbar setup and still get wheelhop at the top of 1st with drag radials at the track...

ive tightened the endlinks tight as hell and adjusted the bars handtight and tried 1turn and then 1/4 turns up to 2.5turns on the bars and nothing is different... its really pissing me off as ive had these things for a year and still havent fixed my wheelhop issues at the track with drag radials (concrete surface) trying all sorts of adjustments... not sure if im missing something that im supposed to be doing while setting these up, or what?

street tires i can sizzle off the car with absolutly no wheelhop...
 

·
Registered
Joined
·
1,200 Posts
went to a different track and no wheelhop other than 1 time for some unknown reason... have 2.5turns on each bar to make them even... but i get all sorts of crunching noises coming up from the frontend of the car now...
 

·
Registered
Joined
·
846 Posts
is it normal for the bars to be at a slight angel or should they be straight up and down? Because I tightened by hand until I couldn't any more than two times with a clamp like the directions say. Should I loosen everything up and make the bolts straight? Im pushing over 400hp so I would assume that some wheel hop will still happen. Thanks, Jason.
 

·
Registered
Joined
·
715 Posts
is it normal for the bars to be at a slight angel or should they be straight up and down? Because I tightened by hand until I couldn't any more than two times with a clamp like the directions say. Should I loosen everything up and make the bolts straight? Im pushing over 400hp so I would assume that some wheel hop will still happen. Thanks, Jason.
the end link bolts should be as straight as possible and also as tight as possible. then when you tighten up the traction bars, once tight, about 1/2 to 1 full turn should do it
 

·
Registered
Joined
·
402 Posts
Discussion Starter #11
the end link bolts should be as straight as possible and also as tight as possible. then when you tighten up the traction bars, once tight, about 1/2 to 1 full turn should do it
I cant get the dang endlink bolts to stay straight when I tighten the traction bar.

the more i tighten it, the more the bolt bends towards the front of the car.
 

·
Registered
Joined
·
715 Posts
if the endlink bolts move when you tighten the traction bars, then the end link bolts are not tight enough. the bushing kits are available at any pep boys or autozone. the bushings should be squeezed out from the gold washers about 1/16 to 1/8 of an inch. then they should be tight enough to tighten the traction bars without moving
 

·
Registered
Joined
·
1,200 Posts
i can tighten the nuts down on the endlinks till the red energy suspension bushings i bought are totally smashed down and they still move forward...

so should i just buy new bushings, tighten them enough so the bushings are the 1/16 to 1/8th inch over the washers, and then what exactly is hand tight on the traction bar because i can tighten the drivers side one till its preatty much all the way tight by hand, the passanger side is harder... so their uneven when i do that... right now i have 2.5turns on each one from neutral, but the bushings are smashed to hell from adjusting them so many times...so im getting noises coming up when coming to a stop or hitting bumps going really slow...

what if delrin bushings were used instead of the polyurethane? then i can really crank down on the endlink bolts and cure the problem, any idea where i can get some of those?
 

·
Registered
Joined
·
715 Posts
are you sure you are not bottoming out the nuts on the bolts and there not tight enough. use washers that we sent to make sure you have enough thread left to properly tighten the bolts. sounds like your drivers side end link bolt isnt tight enough if you can tighten the traction bar all the way by hand.
 

·
Registered
Joined
·
1,200 Posts
are you sure you are not bottoming out the nuts on the bolts and there not tight enough. use washers that we sent to make sure you have enough thread left to properly tighten the bolts. sounds like your drivers side end link bolt isnt tight enough if you can tighten the traction bar all the way by hand.

i bought shorter bolts i believe if im remembering correctly and im using the supplied washers for spacers because i was having problems with them bottoming out with the bolts supplied... im using mopar stage1 lowering springs if this makes a difference aswell...
 

·
Registered
Joined
·
715 Posts
i bought shorter bolts i believe if im remembering correctly and im using the supplied washers for spacers because i was having problems with them bottoming out with the bolts supplied... im using mopar stage1 lowering springs if this makes a difference aswell...
as long as the bars are not hitting the lower motor mount. they will hit stock mounts but not dog bones. only thing i can say is get them tight as possible. mike will be back monday if your still having problems. i cant think of anything else that would cause this.
 

·
Registered
Joined
·
70 Posts
You mentioned that you have the stage 1 springs. The picture from the instructions has the following for a lowered car:

heres what the bolt/washer order should look like for a lowered car:





Hope this helps, I am no expert. Good luck!!
 

·
Registered
Joined
·
1,200 Posts
almost positive they are like that, thanks though...

im putting solid lower control arm bushings in soon so ill buy some new energy bushings for the endlinks and set the traction bars neutral and put 1-2 turns on them and see what that does...

another question i have is how do people launch with slicks with this car? or do slicks help with the wheelhop due to the wrinkle walls...
 
1 - 19 of 19 Posts
Top