Dodge SRT Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
379 Posts
Discussion Starter #1
Ok, so i just put a Kinetic WGA on the car, spiking to 18-1/2, holding 14 to redline. Clamped to 10:1 at redline. Just got home from drinks and dinner, crused the last couple of miles. Got home, popped the hood, and my exhaust mani was glowing hot! :eeeek: Is that normal? I have a 180 thermostat, and the coolant temp looked to be right at 180. Any ideas? I'm about to put a PTP mani and turbo on.
 

·
Registered
Joined
·
773 Posts
ya its normal for a turbo car... turn your defroster on and let the car idle for 3 min or so when you get home (normal turbo cool down stuff) and the glow will go away :)
 

·
Registered
Joined
·
379 Posts
Discussion Starter #5
Yeah, I let it cool right now for 1 minute with the turbo timer. Should I up the time?
 

·
Registered
Joined
·
379 Posts
Discussion Starter #8
Ok, cool. thanks guys. Lol, I was freaking out that first night when I saw that! hahaha
 

·
Registered
Joined
·
769 Posts
Ya mine always glows after a hard run
 

·
Registered
Joined
·
2,162 Posts
Hmmm, I guess I dont drive hard enough or look often enough.
 

·
Registered
Joined
·
1,208 Posts
From what I've heard its pretty normal. You're pushing a bit more boost, so I think that will probably raise your EGT's, making the mani glow a bit more often. Its built to take alot of heat though, so dont worry about it too much. Just up the time on the Turbo Timer, especialy sense you've upped the boost. I usualy set mine to 1minute for the normal drive to work... and 3 minutes if I'm late.
 
1 - 12 of 12 Posts
Top