Dodge SRT Forum banner

1 - 20 of 27 Posts

·
Registered
Joined
·
422 Posts
Discussion Starter · #1 ·
3 weeks ago im driving to work and my car dies. turns out it was fuse 21. No big deal, i thought. Today i swap trany mounts and do a leak test. Found some leaks and fixed them then went for a test drive. Made it about a block from the house and my car dies. I knew what it was and i now have a box of 20 amp fuse in my glove box. i have put in over a dozen fuses and every time i turn over the key the fuse blows again. I want to take it to the dealership but my car is heavly modified. Which doesnt matter in this case because so many STOCK srts are also having this problem. But their still going to give me sit.

Has anyone been able to narrow down what is causing this. I keep reading people do all kinds of things that seem to fix the problem. Some people have even just replaced the fuse and never had the problem again. If you have had this problem and went to the dealership please post what dealer and where so i can have my local dealership get ahold of them. I dont want to be a test car for a small town dealership.
 

·
Registered
Joined
·
906 Posts
fuse 21?

What is fuse 21 for???? to lazy to look up in manual. :lol:
 

·
Registered
Joined
·
422 Posts
Discussion Starter · #4 ·
fuel pump / automatic shut down
 

·
Registered
Joined
·
422 Posts
Discussion Starter · #6 ·
its not just my car. this has happened to several cars. starting to seem like dodge screwed something up.
 

·
Registered
Joined
·
210 Posts
I had the exact same problem kept on blowing that same fuse.The dealer said it was a wiring harness near the intake that wasn't reseated correctly and it kept on moving cause of the engine movement.so they rerouted that harness so it wasn't in the way of anything and problem solved..I also watched them do this of course... :clap:
 

·
Registered
Joined
·
422 Posts
Discussion Starter · #11 ·
bodizapha13 said:
Did you just put in a new FMIC?
not recently, about 4 months ago.
 

·
Registered
Joined
·
422 Posts
Discussion Starter · #12 ·
sirstix said:
I had the exact same problem kept on blowing that same fuse.The dealer said it was a wiring harness near the intake that wasn't reseated correctly and it kept on moving cause of the engine movement.so they rerouted that harness so it wasn't in the way of anything and problem solved..I also watched them do this of course... :clap:
was your car modified? if so did they give you crap about it?
 

·
Registered
Joined
·
7,982 Posts
face engine, look on the right side of the head/block joint.
There is a BIG black 'thinghy' there. make sure the wire is connected to it, and there are no breaks in it.
It right in the way of intakes, so if you been in and out of there, its a good palce to start.
 

·
Registered
Joined
·
460 Posts
Tint, Tail light housing, clear third brake light, Piaa Extreeme whites(got right away when I go the car issue didnt show up right away so it can't be them),and floormats.

:D I know with these mods I must be up to 800 hp at the wheels but I have never dynoed it :D LOL J/k man. I doubt it is any of my mods creating problems.
 

·
Registered
Joined
·
422 Posts
Discussion Starter · #18 ·
MAYBE I FOUND IT!!!

When my buddy and I were doing the turbo upgrade we broke the plasitc cover to the wire which i think is only a ground that goes to the back of the block/drivers side. While checking the harness by the intake i figured i would check the ground it the back. It was on but real loose. Got out some pliers and put it on so tight i cant pull it back off. Replaced the fuse and it fired right up. Its late and theres alot of cops in my neighbor hood becasue a 3yr old walked out of his house so ill do my test drive in the morning. I'll post weather the problem is fixed or not.
 

·
Registered
Joined
·
265 Posts
My car does the same damn thing, however it is the #20 fuse, passenger airbag. Last thursday the car blew the fuse, I had to get it towed to the dealer, and somehow they fixed it an it worked fine. Two days and 150 miles later, the fuse blows AGAIN, same damn thing. It was weird though, when the motor cut off, the tach stayed at the RPM, and didn't fall back down until I flicked the key on and off again. I just trailored the car back to my house today, and the damn car has been out of commission since Sunday. I'll try that ground thing, but if that doesn't work, I'll have to haul it back over to the dealer.

And this last time it broke down, it stopped in the autozone parking lot, and it was extremely embarassing to be stranded there in my brand new car, as the ricers drive by me laughing at my busted ass neon. Needless to say, 2 break downs in 2 days, I've been towing this car all over the fucking place, and I haven't even driven it for 3 days. I'm very pissed off at my Dodge right now.
 

·
Registered
Joined
·
422 Posts
Discussion Starter · #20 ·
i wait a while before getting pissed at dodge. with all the work ive done, mind you im learning as i go, i figure theres a good chance i did something to screw it up. And sure enough it was my fault again. fixed the ground and its all good to go.
 
1 - 20 of 27 Posts
Top