Dodge SRT Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
219 Posts
Discussion Starter · #1 ·
Started on Saturday. The car is bonestock, just rolled 10k miles.

I am getting a melting rubber/ overheating smell from the engine bay, all gages and fluids are perfect, no drippage or leaks that I can see, temp gage is staying normal, also no melting that I can see. I am planning on getting in to the dealership tomorrow or Wednesday, but I need the car for work. Any ideas what it could/might be?
 

·
Registered
Joined
·
1,694 Posts
ummm check to see if the black weather stripping that is on the cowl right about the turbo.. It may have fell off a little and could be melting.. Also look at your 02 sensor wires and make sure none of those may be touching exhaust.. that would be your best bet.
 

·
Registered
Joined
·
219 Posts
Discussion Starter · #7 ·
Dealership: NPF
Looking myself, No road debris, O2 sensors arent' touching anything, Weather stripping looks fine, only thing I did notice was it looks like the remnants of somthing under the turbo between it and the down pipe, oily residue. Smell is getting fainter though, so maybe it is burning off?
 

·
Registered
Joined
·
1,694 Posts
hmmm yeah sounds like maybe you picked up a piece o plastic or something and it got up under the turbo.. pretty hot in there so yeah that coulda been the smell good luck.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top