Dodge SRT Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
994 Posts
Discussion Starter #1
i'm going to try and install this before work.....my tank is at half---should I wait until it is near empty

I can't wait to get it installed, but I only have 3 hours and want to make sure that I have enough time to get this done before work in case I run into any snags

Also-do I need to disconnect the battery?

man I hope this is as easy as it looks, easier would be better
 

·
Registered
Joined
·
1,924 Posts
I was wondering how do you unhook or unclip the fuel line. Is it the blue pc that is showing. Other than that I think I got it.


Thanks
 

·
Registered
Joined
·
801 Posts
Me and friend did both of ours in 30 min. I was first and it took like 20 min, then we did his in like 5min. The longest part is the C-clip and thats not even hard, just alittle time consuming.


My tank was over half full when I did it. Enjoy the extra boost this brings :eveilgrin
 

·
Registered
Joined
·
1,440 Posts
John, I got my 80 psi installed tonight....everything was a snap. Is the whine I'm getting from the fuel pump going to hurt anything? Will it drastically hurt the life of the pump? or will it go away?
 

·
Registered
Joined
·
561 Posts
doens't go away, PTP commented that with 90PSI mods the pump whine was way loud and not very reliable.

so 80 psi will whine louder than 58PSI. but 80 should be reliable.
 

·
Registered
Joined
·
1,440 Posts
Will the Walbro 255 pump make that same whine noise, or will it go away once the new pump is installed? It won't be for about a month or so before I get it installed, so will the stock pump hold up?
 

·
Banned
Joined
·
32,448 Posts
EssArTee-4 said:
John, I got my 80 psi installed tonight....everything was a snap. Is the whine I'm getting from the fuel pump going to hurt anything? Will it drastically hurt the life of the pump? or will it go away?
With some of them the fuel pump will whine a bit (like stg 3) Walbro has given the OK to run up to 90 psi and I ran one at 110 psi for 3 weeks (dam that was a real loud whine) and it took it like a champ. I wouldnt worry since the pump can take it with no issues according to Walbro, thanks.
 

·
Banned
Joined
·
32,448 Posts
EssArTee-4 said:
Will the Walbro 255 pump make that same whine noise, or will it go away once the new pump is installed? It won't be for about a month or so before I get it installed, so will the stock pump hold up?
See post above, yes the 255 pump will make the same noise.
 

·
Registered
Joined
·
994 Posts
Discussion Starter #12
well, the idle is super smooth----haven't had a chance to WOT b/c my S2 WGA is still rocketing up at first sign of WOT, but now the this FPR is in I feel a lot safer if I get on it w/o paying much attention and get too high a boost

i'm also hearing a stronger wooshing sound coming from the engine bay under mild low rpm acceleration--
anyways, I will post up any news on this mod as soon as I can stabilize my S2 WGA to 16-18 peak
 

·
Registered
Joined
·
561 Posts
got mine installed.
the top o-ringwas lost i nthe tank hole and it took me 30 minutes fishing with a small allen wrench to fling it out! I couldn't see it even with a mirror and flashlight.

but after that I just comrpessed the snap ring with pliers to help me snap it in.
its in and working well so far. I don't notice and more whine either.
 

·
Registered
Joined
·
8,043 Posts
I just got mine today in the mail. I can't wait to put it on. I feel safer already, and ready for when the track opens on 4/8/06. Hopefully I have my fmic, and crash bar installed by then. Thanks ptp real quick shipping.
 
1 - 14 of 14 Posts
Top