Dodge SRT Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
513 Posts
Discussion Starter #1
I just purchased one off a member on here and I was wondering how do you adjust it cause I got on it and the boost spiked at 30psi. After that I just drove nice and slow home. Also it has a 18lbs spring in it so I just need to turn it down about 10psi.
 

·
Registered
Joined
·
1,183 Posts
The diaphragm might be torn.

You need to take it apart and check it.
 

·
Registered
Joined
·
639 Posts
yup

Panzer said:
I just purchased one off a member on here and I was wondering how do you adjust it cause I got on it and the boost spiked at 30psi. After that I just drove nice and slow home. Also it has a 18lbs spring in it so I just need to turn it down about 10psi.

it is ripped, i went through a few of them.
 

·
Registered
Joined
·
5,795 Posts
Contact forge motorsports and ask for a replacement, they will help you provided you don't come off as jerk or rip them because it failed. In the mean time put the stocker or another known good one back on till they send a new replacement diaphragm.
 

·
Banned
Joined
·
1,276 Posts
You might want to get the Yellow spring too. It will eliminate most Flutter and has a similar spring rate as the AGP WGA. I previously ran my Forge with their original Blue spring, but at the "No Preload" setting, I still got flutter and a whole lot of PTB. Now with the Yellow spring I can adjust it to near max and spike 19-20psi and hold 17 to redline with S2. I have it hooked up directly to the factory lines and have a small bleed-cap-mod to the factory bleed on the black/green line solenoid. This bleed cap prevents the ECU from trying to fight for control of the new WGA by limiting the amount it bleeds. With this setup I get just enough traction in 1st & 2nd then all the boost I need for 3-5th.
 
1 - 9 of 9 Posts
Top