Dodge SRT Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1,184 Posts
Discussion Starter #1
First time in the SRT-4 for me. Mods = K&N drop in filter, BOV conversion plate, and Stage 2 WGA. On stock street tires:

60ft: 2.191
330: 5.954
1/8: 9.032 @ 80.52
1000: 11.676
1/4: 13.948 @ 98.77 <-- I think I let off early for some reason. :ftard:

60ft: 2.209
330: 6.021
1/8: 9.175 @ 78.85
1000: 11.844
1/4: 13.812 @ 311.63 <-- Speed obviously messed up. :lol:
 

·
Registered
Joined
·
1,184 Posts
Discussion Starter #3
AnotherNeon said:
how is everyone gettin good 60' i cant get anything better than 2.3 good times though
What RPM are you launching at? This may sound weird, but when I pulled the 2.191 60 ft time, I launched from idle (basically idle, but my foot was resting on the gas, so maybe it was 1,000 RPM). When I tried launching from a higher RPM, I spun bad, got violent wheel hop and had to let off in 1st. My best times were when I wasn't even "trying". I just let the clutch out and gassed it at the same time. Give it a try.

Here's my run launching from a higher RPM. I was racing a stock 2004 GTO, who also messed up his launch too. This wound up being the most run race of the afternoon even though it was my worst time. I think I let off too early again during this race because it was side by side the whole way down the track. I was actually pulling at half track.

SRT-4 / GTO
R/T: 0.410 / 0.415
60ft: 2.320 / 2.224
330: 6.147 / 6.104
1/8: 9.256 / 9.251
1/8 mph: 79.95 / 79.03
1000: 11.933 / 11.914
1/4:14.246 / 14.161
1/4 mph: 96.72 / 100.53
 
1 - 4 of 4 Posts
Top