Dodge SRT Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Ive had my SRT 4 for a few days now and I notice a faint click in the engine while its running. It accelerates when you press the gas. Im wondering if its a busted valve or if that noise is normal.
 

·
Registered
Joined
·
244 Posts
graddonxc said:
Ive had my SRT 4 for a few days now and I notice a faint click in the engine while its running. It accelerates when you press the gas. Im wondering if its a busted valve or if that noise is normal.

Thought it was supposed to accelerate when you pressed gas? ahhh iam so confused, does it slow down when you break?:rofl:
 

·
Registered
Joined
·
708 Posts
Judging from your avatar you have and 05'. From what I've read and heard some of the 05's have a defect on the exhaust side cameshaft. The lobes on the passenger side are oversized and thats why you here that clicking noise. I get it too and so does a friend of mine who has 75k on his car with no problems. Also there is supposedly a batch of early 05's that went out with bent valves but I highly doubt yours is one of them. I wouldnt worry too much. Just listen and make sure it doesn't get any worse.
 

·
Registered
Joined
·
1,512 Posts
I think it's just the Cams... If it's comming from the passenger side put your hand on the valve cover towards the rear edge. You may be able to feel the noise, it's real slight. If this is it , I'll call it the normal cam noise. Of course this is a guess but you should be ok. These motors are pretty strong and the check engine light will usually come on without delay when there is a real serious problem, however when things go bad you'll know without a doubt. I've see a hole blown through a guys block because he forgot to turn on his meth injection during high boost 25+psi.....

PS nice color....
 
1 - 5 of 5 Posts
Top