Dodge SRT Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
403 Posts
Discussion Starter #1
ok ill try and explain this as simple as possible. the bushing on the front has an oval shape to it and fits around the swaybar and snugs into the subframe.the rear bushing is a half oval and flat on top and sits flush on the frame.
so i ordered some bushings from energy suspension and went to install then tonight. i installed the rears no problem. when i went to go do the fronts the bushing looks exactly like the rears :paranoid: i went ahead and installed them but something just doesnt seem/look right, i dunno maybe it is?? any help guys?? thanks
 

·
Premium Member
Joined
·
929 Posts
STEALTHMODESEDAN said:
ok ill try and explain this as simple as possible. the bushing on the front has an oval shape to it and fits around the swaybar and snugs into the subframe.the rear bushing is a half oval and flat on top and sits flush on the frame.
so i ordered some bushings from energy suspension and went to install then tonight. i installed the rears no problem. when i went to go do the fronts the bushing looks exactly like the rears :paranoid: i went ahead and installed them but something just doesnt seem/look right, i dunno maybe it is?? any help guys?? thanks
It's not the correct bushing... What sway bars are you running? If you read the sway bar sticky it talks about the issue in there and has a link to a previous post about the bushings issue.
 

·
Registered
Joined
·
403 Posts
Discussion Starter #3
yea i just read that :knockhead i e-mailed the guy so i can get the correct ones coming,im just running the stock front bar. thanks for the input though man :thumbsup:
 
1 - 3 of 3 Posts
Top