Dodge SRT Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter · #1 ·
Does sound like an ok set up, or would I still need a block off plate or what. Please lemme kno. Thanks
 

·
Registered
Joined
·
626 Posts
yeah you still need a block off plate. decent setup if the turboxs is what you're lookin for. do a search on hardpipe kits. i've heard the ED's have some rubbing issues.
 

·
Registered
Joined
·
1,257 Posts
JustANeonButBadass said:
yeah you still need a block off plate. decent setup if the turboxs is what you're lookin for. do a search on hardpipe kits. i've heard the ED's have some rubbing issues.
ED Hardpipe kit has rubbing issues!???!!???
 

·
Registered
Joined
·
4,896 Posts
those turboxs rfl's have a problem with the piston sealing correctly. get a good and fast acting diaphragm unit, like the greddy type-s.
 

·
Registered
Joined
·
369 Posts
I have the ED Pipes with the HKS....no rubbing issues. There are people out there who fail to put the pipes on straight and examine what they are doing before they tighten their clamps. They have the issues with "rubbing". Usually, they get back under the hood and adjust it with no problem.

Check your work....twist the pipes to the right angle, then torque down the clamps. You should be fine. It is not that difficult.

If you still have problems, ED are good people (person?).
 

·
Registered
Joined
·
1,257 Posts
danpam1024 said:
I have the ED Pipes with the HKS....no rubbing issues. There are people out there who fail to put the pipes on straight and examine what they are doing before they tighten their clamps. They have the issues with "rubbing". Usually, they get back under the hood and adjust it with no problem.

Check your work....twist the pipes to the right angle, then torque down the clamps. You should be fine. It is not that difficult.

If you still have problems, ED are good people (person?).
cool, thanks for the info
 

·
Registered
Joined
·
11,093 Posts
danpam1024 said:
ED are good people (person?).

Im scitsophrenic so yeah, its people. :)


I have seen some hardpipes rub. WHen i install it it no longer rubs. When you tighten the hose clamps it tends to move the pipes at times. YOu have to hold the pipe in position when you do.


As for the RFL, i did not make a flange for it because they stick after a while. The piston wears down and cocks after some time.
 
1 - 7 of 7 Posts
Top