Dodge SRT Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Stage 2
3 inch exhaust no cat/muffler
Mopar CAI
21 psi stock turbo
104 octane"Gt 260 plus"
Dsp tune modified 93 tune...
24.5 inch slicks
Full weight plus me 285lbs. :/
 

Attachments

·
Registered
Joined
·
6,698 Posts
yea thats no good. thats what a stock srt can do on slicks. you need to go hunting for problems. compression test, boost leak check, spark plug check, dyno it, data log it something. car is lacking power.

also with boost that high and a stock ic your blowing more hot air then anything. actually robbing power. once you get the current issue look into a big fmic and/or meth injection if you want to continue running that high of psi. until then i'd back it down to 18 tappering to 15
 

·
Registered
Joined
·
22 Posts
Discussion Starter #3
Yea I though it was a bit slow. And forgot to mention I do have a bfmic. And last night about second run I started hearing a whistle sound I'm sure I have a boost leak. Would a leak rib me that bad?
 

·
Registered
Joined
·
6,698 Posts
definitely. cars this age need regular maintenance. being a turbo car it needs even more. normal wear and tear have taken there toll on hoses, clamps and plugs throughout the car. once you fix one leak don't be surprised if another shows up. invest in a boost leak tester to speed up the process
 

·
Registered
Joined
·
22 Posts
Discussion Starter #5
The car pulls very hard I believe from what it was when I bought it with stock 93 tune. Nothing like my 50trim srt4 did though. I have a slight hesitation/bog going into second gear. So that's what I gonna say it cutting me down on times. And I will get one soon for sure
 

·
Registered
Joined
·
22 Posts
Discussion Starter #6
So should I technically be able to beat this guy here is the full time slip. He out performed me in everything time wise but I trapped 2mph more then he did
 

Attachments

·
Registered
Joined
·
6,698 Posts
your trap was higher because your 60 ft was worse. don't be surprised once its running right to see your et drop a half second but the mph stay the same or close to it.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #8
Well I was able to get to the track again last night and I had pulled off slightly better time. Does this still seem slow to you guys. I thought I had the boost leak fixed but behold after my second run its back. Not as bad but it's back.
 

Attachments

·
Registered
Joined
·
22 Posts
Discussion Starter #13
Well at this point I'm probably talking to myself. But I have the new gasket installed and OMG it's a completely different car. It would only chirp second sometimes when I was in a WOT pull, now it will spin through all of second gear. The car dosnt big down in between shift. I'm pretty happy all it was was a gasket.
 

·
Registered
Joined
·
7,310 Posts
Yeah, that's a pretty good chunk missing but at least it was something relatively simple and cheap. If the computer was compensating for a cylinder running off due to more knock, MAP sensor reading a bit off, etc. you might also want to unplug the battery or pull the ASD power fuse to reset the computer's adaptive settings unless you're going to drive it a lot before heading back to the track if you're looking for consistency.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #15
Yes I was stoked, it's pretty much only driven at the track. It feels more like my old srt4s now. I can't wait to get back to the track! And I have already reset everything and took it for a test spin.. Hopefully I'll get back to the track soon and let you guys know how it goes
 
1 - 15 of 15 Posts
Top