Dodge SRT Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Ok Guys i need your help i bought this car from a friend was told it was a broken shift selector in fact it was a broken 3/4 shift fork and 3rd sync. I replaced the fork with the billet and the sync with carbon fiber, also have billet selector, billet extender, ported mani, Big FMIC, rebuilt turbo, put a yellow top in, and replaced the clutch disc. Did all the work myself (mostly my brother) and havent got to drive it yet!!!! The clutch will not engage but goes in all gears when car is off. Everyone keeps telling me there is air in the cltch line even though we bleed in through the slave cylinder and pedal cause i had to replace that as well. Does anyone have any ideas of a better way to get the air out of the lines or what else the problem could be???? plez message me or text or call me 7024205112 with any ideas before i push this car off a cliff or hang myself i really need help we are stuck and we have about 2500 bucks in parts alone so plzzz give me any thoughts thanks alot...
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
the pedal goes down like there is a clutch. At first there was no pedal then i bled it and it feels fine.
 

·
Registered
Joined
·
55 Posts
i just test drove one the same way.. Let me text him and see what he found out i know he was taking it to have it looked at.
 

·
Registered
Joined
·
55 Posts
He just text me back and said he had to take the whole clutch off and reinstall then was working fine....IDK
 

·
Registered
Joined
·
587 Posts
What do you mean by carbon fiber sync? Synchronizers are not made out of carbon fiber, I think you have some wrong information. It sounds like your clutch wont disengage as well, please clarify.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
DCR website sells carbon synchros no wrong info but thanks for the concern. And the clutch will not disengage or engage i have a new slave i ordered
 

·
Registered
Joined
·
3,118 Posts
Carbon Kevlar

So, you push the clutch to the floor and it wont go into gear while the car is on? Is the pushrod on the slave pushing the fork in?
 

·
Registered
Joined
·
587 Posts
DCR website sells carbon synchros no wrong info but thanks for the concern. And the clutch will not disengage or engage i have a new slave i ordered
Carbon coated, not carbon fiber like your original post said. Your clutch is either disengaged or engaged, it cant be neither, sounds like its engaged and you have a problem with either the mechanical or hydraulic part of the clutch disengagement mechanism. Have you adjusted the pedal? The master cylinder may not be getting enough travel to disengage it.

If your slave isn't leaking, it is most likely not bad
 

·
Premium Member
Joined
·
913 Posts
OK easy test make sure u have a lot of room and Turbo timer is off. Put the car in 1 or R when its turned off then push clutch all the way in and start. If it takes off obviously turn it off. This would mean that the Clutch is not disengaging. Lmk done tons of trans rebuilds ( with DCR parts )

Sent from my DROID RAZR using AutoGuide.com App
 

·
Registered
Joined
·
991 Posts
Yeah what ^^^ he said....bump on the starter and if the car starts moving while its cranking or running WHILE your foot is on the clutch...then the clutch isn't disengaging. Check master cylinder, slave cylinder, slave and master rods, or pull the inspection plate (on tranny to the left of the slave cylinder near the cold side pipe and pcm) and look to see if the TOB and fork are opporating smoothly.

Sent from my Droid3 using my Droid3 and looking at my Droid3....oh and I used an autoguide app
 

·
Registered
Joined
·
9 Posts
Discussion Starter #13
i have some new info i started the car in gear and drove it with no clutch. when its starts up it doesnt stall and there is a tiny bit of clutch in 1st gear any ideas????
 

·
Registered
Joined
·
9 Posts
Discussion Starter #15
how dont they make sense? when the car is off i put it in gear and start the car in 1st with the brake on it stays still and doesnt stall with the clutch in. Then it rolls a lil bit when i release the brake and when i release the clutch pedal it pulls like normal but i have to rev match to get it to go into other gears going up or down. everyone is telling me to get a new slave and master so i guess thats my new route
 

·
Registered
Joined
·
3,118 Posts
Check the slave to make sure its not loosing pressure. If its good, post it up and someone will give you the next step.
 

·
Premium Member
Joined
·
913 Posts
Did u replace the slave and master yet buddy. Lmk I am 100 percent sure that's the problem.

Sent from my DROID RAZR using AutoGuide.com App
 

·
Premium Member
Joined
·
913 Posts
What was the resolution to the problem?

Sent from my DROID RAZR using AutoGuide.com App
 
1 - 20 of 22 Posts
Top