Dodge SRT Forum banner
1 - 20 of 48 Posts

·
Registered
Joined
·
6,282 Posts
Discussion Starter · #1 ·
Cause they might look like mine.

Stock Plugs @ 21,000 miles. Replaced with colder Densos and better wires today.

 

·
Registered
Joined
·
906 Posts
Ha

TOASTY! :lol:
 

·
Registered
Joined
·
428 Posts
When I switched from stockers to NGK's (& MSD wires) I noticed no change in running smoother at idle or thru-out the rpm range. But after switching to my Denso's w/wires, I notice a drastic change in how smooth the car idled and went up thru the rpm ranges.
 

·
Registered
Joined
·
6,282 Posts
Discussion Starter · #5 ·
AnthonyV6 said:
When I switched from stockers to NGK's (& MSD wires) I noticed no change in running smoother at idle or thru-out the rpm range. But after switching to my Denso's w/wires, I notice a drastic change in how smooth the car idled and went up thru the rpm ranges.
I haven't had a chance to go drive my car around yet. But I'm going to in a little bit. I didn't think they would have been that bad.

"Can you smelllllllll what the SRT-4 is cookin?" My plugs.
 

·
Premium Member
Joined
·
1,786 Posts
:eeeek: Damn, last time I checked, my plugs didn't look blurry?!? :lol:

haha....what do the electrodes look like?
 

·
Registered
Joined
·
6,282 Posts
Discussion Starter · #7 ·
Yeah sorry, I actually took like 15 pictures and that was the best.

Electrodes are gone.
 

·
Registered
Joined
·
1,363 Posts
anyone got a parts number for sparkplugs.com for the densos?
 

·
Registered
Joined
·
59 Posts
Will the Densos work with MSD wires? If not will any?
 

·
Registered
Joined
·
682 Posts
Stock champion plugs suck. Mine fouled out at around 2000 miles. I couldnt even get into boost and it would break up and fall on its face.. replaced them with v-zooms from NGK, gapped at about 0.38 and those things made a nice difference
 

·
Registered
Joined
·
59 Posts
Cool I'll give them a try.
 

·
Registered
Joined
·
799 Posts
If The Electrodes Are Not Rounded Off Or Tappered Then The Plugs Are Still Ok.i Have Stock Champions With 13000 Miles I Just Checked Them When I Did Compression Test And The Gap Was At .52 And My Car Idels Smooth And Still Runs Great.mine Is All Stock.i Do Have Msd Wires Tho.our Gas In Ca Is Lots Diff Than Other States This Could Be Why I Dont No.
 

·
Registered
Joined
·
500 Posts
Do you/did you idle for long periods of time, especially before removing them???
It could be worse, they could be white/tan instead of black/tan...

Wow, at the rate some people here change theirs and try different gaps and brands, you waited a long while... You're not a plug virgin anymore... :clap:
 

·
Registered
Joined
·
6,282 Posts
Discussion Starter · #18 ·
Do you idle for long periods of time, especially before removing them???
It could be worse, they could be white/tan instead of black/tan...
Yes actually, my turbo timer is usually set for at least 2 minutes.

Wow, at the rate some people here change theirs and try different gaps and brands, you waited a long while... You're not a plug virgin anymore...
I did wait a little too long. But I'm glad I did now because for awhile I wasn't sure on which plugs and gap that I'd be happy with. I'm very happy with this setup.
 

·
Registered
Joined
·
1,460 Posts
Yea changed mine @3,000 or 4,000 with champions as well as msd wires, now I have 8,035 miles on them but they werent that bad just wanted to change them before s2 w/o toys. :thumbsup:
 
1 - 20 of 48 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top