Dodge SRT Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
1,530 Posts
Discussion Starter · #1 ·
so i put in a whole new block and head in my car and while i had it apart i got a new clutch. i put everything in. took it off the lift, started it for the first time, put it in first and let go of clutch and nothing happened. it just sat there like i was still in neutral. when i pu sh the pedal all the way to the floor i hear a loud squeeking/squeeling sound and i can feel all the vibrations of the motor in the clutch pedal when i push it about halfway. what is wrong? is TOB installed wrong or something? or is it just a bad new clutch? i need help because its already been one week without my car and i cant go another week! help asap!
 

·
Premium Member
Joined
·
913 Posts
Problem

What kind of clutch do you have?

Does it go into gear with engine running and not pushing the clutch in?

Let me know i have done a lot of clutches.
 

·
Registered
Joined
·
1,530 Posts
Discussion Starter · #3 ·
its a rebuilt stock clutch. i took it to a local shop that resurfaces the clutch disk. i havent tried to put it in gear without pressing in pedal. all i know is that it squeels bad when clutch is to the floor which i am guessing is the TOB and i can feel all the engines vibrations through the pedal when pressed in about halfway.
 

·
Registered
Joined
·
1,530 Posts
Discussion Starter · #5 ·
when i went to buy a TOB they had three different kinds for the srt4. whats the part number i should have got so i can compare to what i bought?
 

·
Banned
Joined
·
32,448 Posts
cooper232 said:
when i went to buy a TOB they had three different kinds for the srt4. whats the part number i should have got so i can compare to what i bought?
Was that from Dodge or the local parts store? Only get the Dodge TOB, several have had the others and they kill the pressure plate for some reason. I believe that there was a thread on getting only the Dodge unit when doing a clutch.
 

·
Registered
Joined
·
1,530 Posts
Discussion Starter · #7 ·
so you think i should try only installing a new TOB first or should i just get another clutch and bring this one back?
 

·
Banned
Joined
·
32,448 Posts
Well I recommend pulling it all apart to see what the problem is. They could have installed the PP wrong as well. To much going on to not know "what" could be the deal.
 

·
Registered
Joined
·
164 Posts
yikes

if the shaved the surface at all you better hope the flywheel bolts that go into your crack arn't pushed on the crank bearing .... I've seen this done before ... you may want to check that out .. might not be the problem .... but just by chance . Put it in the back of ur head.
 

·
Registered
Joined
·
1,530 Posts
Discussion Starter · #11 ·
yea when i push the pedal it still feels the same. its just as hard to push as before but when its about halfway the pedal vibrates up and down with the sound of the motor. and when i push the clutch hard to the floor it makes a squeeling sound that isnt a constant sound. its like a squeeling sound that is also pulsating with the speed of the engine.
 
1 - 11 of 11 Posts
Top