Dodge SRT Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey everyone. I would appreciate any help. I hope somebody here knows about calibers because the caliber forums are dead. I just bought an 08 caliber srt4 and I just installed ms1k. The car only hits 5 psi when it should be 15+. I did a boost leak test and discovered a t with a missing hose and another empty connection off of the back of the intake area. I connected the t to the back of the intake vacuum solenoid and I think I solved that problem.

So i boost leak tested it again and saw that the aftermarket bov is leaking. Could that be the problem? Or could it be the routing of the vac lines? The mods are mpx catless downpipe, ms1k, 2 step/wotbox, and hks ssqv knock off. I have some pics of the vacuum lines. Thanks for the help.
 

Attachments

·
Registered
Joined
·
3 Posts
Discussion Starter #3
That is very possible. Get a new gasket or a new b.o.v set up. How did you do your leak down test
Yeah I bought a new bov setup. But the real problem was that I had to reset adaptives with my scangauge. Now it's hitting full boost and running like a beast!
 

·
Registered
Joined
·
12 Posts
Yeah I bought a new bov setup. But the real problem was that I had to reset adaptives with my scangauge. Now it's hitting full boost and running like a beast!
Im jealous. Im not boostin much at all. Pretty sure since my vss in my getrag288 trans ai t workin, that its not allowing me to boost. Basically throwing my boost into limp mode. I asked if i can rerun my van lines so its not on pcm. Run from turbo to wastegate. Been waiting for a reply. Seen someone else say it but i wanted to confirm that i read it right. Tho i have a pt gt srt4 stage 1
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Have you tried clearing the cel when you go into limp mode? That used to fix it for me.
 

·
Premium Member
Joined
·
4,330 Posts
Im jealous. Im not boostin much at all. Pretty sure since my vss in my getrag288 trans ai t workin, that its not allowing me to boost. Basically throwing my boost into limp mode. I asked if i can rerun my van lines so its not on pcm. Run from turbo to wastegate. Been waiting for a reply. Seen someone else say it but i wanted to confirm that i read it right. Tho i have a pt gt srt4 stage 1
ok so yes, you can go off of pcm controlled boost by eliminating the solenoids all together, BUT i dont think it's wise until you get the VSS issue corrected.
 

·
Registered
Joined
·
12 Posts
Hopefully gonna order it today. Ive learned how fast im going with a alt speedo. Just sucks saying "i have a turbo" but yet dont feel like its turbo'd. Just wanted to see if i could infact run straight from top turbo line to wastegate
 

·
Premium Member
Joined
·
4,330 Posts
you can. and the PCM will have no control over how much boost is there. You'll run only the spring pressure of the wastegate unless you put some other type of boost controller inline. But again, i would recommend against doing this until after the VSS issue is figured out.
 

·
Registered
Joined
·
12 Posts
With the vss. I believe it may have been me. Fuck it ill admit it just incase. I pulled trand to check clutch and slave cylinder. Wanted new seals and make sure all was good. My block on my stand moved and i feel thats how 2 out of 3 wires not broke. Now i did solder them back on but speedo is still not working. Idr if it worked before hand
 

·
Premium Member
Joined
·
4,330 Posts
hey man, shit happens.
 

·
Registered
Joined
·
12 Posts
Gonna try and fimd a vss. Guy sold it before i could pay the guy. Which is fine. But we had it set up and when i asked for info it was gone
 

·
Premium Member
Joined
·
4,330 Posts
what makes finding the part so difficult? I understand the part isnt available new anymore, but were there not many PTGTs with that trans made?
 
1 - 13 of 13 Posts
Top