Dodge SRT Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
701 Posts
Discussion Starter · #1 ·
I recently installed Evilcreations BFMIC and new plugs 1 step colder NGK iridium. The problem is when i WOT like on the freeway in 3rd or 4th or downshifting from 5th to 3rd the car jerks almost like air going into the turbo and sending it back out making a bubble causing the car to jerk is kinda what it feels like. it struggles to go. it jerks like every 2 seconds when going WOT.

Im not sure if piping could be an issue. i have AGP's Upper hard pipe but im using the stock lower hard pipe for the new intercooler. has ANYONE had this problem with a big intercooler on a small turbo? i checked for boost leaks and everything seems fine. im still boosting my normal boost and it cant be the plugs. The only thing is could this happen if my plugs arent gapped? cause they arnt.
 

·
SRTforums Nazi Admin
Joined
·
16,228 Posts
gap the plugs to .023 then try again ;) it will help they are probably at .052 or something like that right now and what kind of plugs 4306's?
 

·
Registered
Joined
·
701 Posts
Discussion Starter · #3 ·
i think so the number is LZTR6AIX-13 from www.modernperformance.com

I was tryin to find the spark plugs thread on the forums but couldnt find it to double check i think your right though. are you sure about a .023 with my mods? i was told like .035 roughly
 

·
SRTforums Nazi Admin
Joined
·
16,228 Posts
stock number: 4306 part number: LZTR5A-13 these are the ones i bought and the ones that are suggested for the car ;)
 

·
Registered
Joined
·
701 Posts
Discussion Starter · #6 ·
have you had this problem before? are you for sure this will fix it? and im not boosting anywhere near 20-22 psi. im boosting 15.5. wouldnt a .035 be better for me at my current state?
 

·
SRTforums Nazi Admin
Joined
·
16,228 Posts
it would be a lot better than a .052 like they came :) i am going w/ the 300hp guide ;) i just need to get the return line kit and i got all of it and some ;)
 

·
Registered
Joined
·
701 Posts
Discussion Starter · #8 ·
yeah but i asked if u had any familer situations with this jerking at WOT problem. im looking for someone who may have experience the same problem. i appreciate your help and all no doubt but im lookin for similar peopel with the same problem or had it before
 

·
SRTforums Nazi Admin
Joined
·
16,228 Posts
nope never had this problem before but i am telling u that is the problem gap them and there u go u are going to be good LISTEN TO ME :)
 

·
Registered
Joined
·
701 Posts
Discussion Starter · #10 ·
i will gap them for sure. :D ty
 

·
SRTforums Nazi Admin
Joined
·
16,228 Posts
:thumbsup: no prob
 

·
Registered
Joined
·
3,166 Posts
i had the same problem, car would jerk a lot, especially 4th gear. i tried replacing spark plugs, did that 4 times and it turned out to be TPS...
just something to look for. our cars are well known for that
 

·
SRTforums Nazi Admin
Joined
·
16,228 Posts
if it was the throttle position sensor yes i know all about it very expensive part $75 for a pos ;) but anyway he would have a hanging rev meaning the if he gave it some gas it would stay at those rpms until he put the clutch in more than likely that is what happened to me when mine went for the 1st and 2nd time haha
 

·
Registered
Joined
·
701 Posts
Discussion Starter · #14 ·
so your thinking it could be a TPS problem? hm?
 

·
Banned
Joined
·
862 Posts
try gapping the spark plugs at .35 then let us know if it still happening and we can go from there.
 

·
Registered
Joined
·
701 Posts
Discussion Starter · #16 ·
kk will do
 

·
Registered
Joined
·
701 Posts
Discussion Starter · #17 ·
gapped the plugs myself to .035 and everything turned out good. i appreciate everyones help. no more jerkinat WOT:clap:
 

·
Registered
Joined
·
3,187 Posts
swbd4l i tried messaging you but your inbox is full, where did you get your wheels from?? those things look sick!:thumbsup:
 

·
Registered
Joined
·
701 Posts
Discussion Starter · #19 ·
1 - 20 of 21 Posts
Top