Dodge SRT Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
96 Posts
Discussion Starter #1
I just built a leak tester and tested my 05 srt-4. I pluged the hose on the intake pipe. I set my compressor to 20psi so souldnt i read 20psi at the boost guage I was getting nothing i upped the pressure on my air compressor to 30psi and was getting 5psi on my boost guage. Am I suposed to have more psi comming from my air compressor? or did I forget to plug another hose? What should be pluged when testing? I am still getting 7-9psi in 1st and 12-14 psi while in 2,3,4 gears. so if i wanted to see that on my boost gage on a test i would have to have like 50-60 psi going in? I must be doing something wrong. please help.
 

·
Registered
Joined
·
96 Posts
Discussion Starter #2
by the way the key is in the on position
 

·
Registered
Joined
·
96 Posts
Discussion Starter #4
but the intake is connected to the inlet side of the turbo. I plugged all the lines that go into the intake so i dont see it being a problem. I've read on other threads that is okay to connect it to the sri
 

·
Registered
Joined
·
6,109 Posts
maybe you just have one hell of a boost leak.
 

·
2013 FF Pizza League Champion
Joined
·
10,991 Posts
I was told on the phone by GLHS837 to put the tester DIRECTLY on the turbo inlet. Try it and see what you think.
 

·
Registered
Joined
·
2,613 Posts
hey, PM me ok, I have hosted 2 boost leak tests day in my area and any one that know me will tell you that I'm the one to talk to, I will give you all the help you need man, PM and send me pics of your tester and i will show you how I do the set up, no car leaves my shop with out holding 20+ psi, and don't worry about the boost gauge during testing, you need a tester with a gauge on it, like i said PM an email address and I'll send you pics of mine, and will even make one for you for a good price.
 

·
Registered
Joined
·
96 Posts
Discussion Starter #8
i just sent you a pm.
 

·
Registered
Joined
·
96 Posts
Discussion Starter #10
sorry that its so easy for you
 

·
Registered
Joined
·
12,239 Posts
Well you should hold enough boost to be able to see what your at in the car. What throttle body do you have? My zapp was terrible before i fixed it i couldnt even hold over 10psi. bigD has donr alot of srt-4's so he would know how to help if you have aim he is on there also
 

·
Registered
Joined
·
67 Posts
Read in your sig you've got the Mopar BOV. So far I've haven't met anyone with the Mopar BOV that DIDN'T have boost issues. Word to the wise, ditch the "Fisher-Price: My First Blow Off Valve" and get a good one if you really want the noise.

9/10 times that's what is causing the leak. I know what the thread said... but if he's still having issues and doesn't know how to test the leak - it doesn't take long to knock that POS outta there. They all eventually spring a leak and are good for nothing. I don't know why but I've never heard good news from long-term use of that thing.
 

·
Registered
Joined
·
96 Posts
Discussion Starter #14
its just odd because b4 the winter the car was holding 17 psi at redline now i cant even get over 10. I will try doing another test and seeing where its coming from. live and learn i guess
 

·
Registered
Joined
·
67 Posts
Your boost will be lower with colder weather. Your boosting like a stock SRT-4 right now.
 

·
Registered
Joined
·
96 Posts
Discussion Starter #16
at what temp will you see boost rise?
 
1 - 16 of 16 Posts
Top