Dodge SRT Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
143 Posts
Discussion Starter · #1 ·
Ok, so i have a AGP WGA, Turbo XS MBC and a SAFC. I have the wastegate set to 13 psi. When i try to turn up the MBC to set it at about 17 psi, and the car doesnt like that. It almost feels as if i am hitting the rev limiter around 15 psi and it wont climb anymore from there. Also when i am in 3rd gear and floor it from about 2-2.5K, the car starts bucking all crazy and i hear popping noises from under the hood. I can even get the car dynoed because of this because they do 3rd gear pulls from about 2K RPM. When i first got the car and had just the Turbo XS MBC, everything worked fine. It also worked fine after the AGP WGA install so im totally lost. All help is apperciated.

Thanks
Bryan
 

·
Registered
Joined
·
23 Posts
if i were you i would just set it up the way it used to be.... you said it use to work prior to you adding the SAFC... i dont think you need to use that ... i think that Stage 1 would be a wiser investment... i have stage 1, spring mod, and a Greddy Profec B spec II EBC and the ecu does all the tuning for me... i never have to adjust the air/fuel
 

·
Registered
Joined
·
23 Posts
the reason the car when put back to stock only runs 4psi is because it was put into a saftey mode.... when i first had my car... i pulled the line on the wastegate (fun... but very stupid) when i then put it back to stock it was in a saftey mode and wouldnt hit more then 4-5psi... what i had to do was disconnect the battery terminal and then leave it for a min. or more to allow the vehicle's ecu to reset.... should be just fine after that....
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top