Dodge SRT Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
144 Posts
Discussion Starter #1
Its been about 2 weeks and I still can not find what the problem is. The car will go to 19psi in second and drop to about 10 or 11. Hits about 16 or 17 psi in third gear and drops crazy fast to about 10 psi and fourth gear is really nonexistent anymore. So I checked my wastegate and tightened everything up. Checked the IC pipes and no problem there. Checked all the hosing and everything seemed to check out ok. So wtf am I doing wrong? Is there something that I am missing? Here is a list of my mods
AGP wastegate
AEM intake
CCA FMIC
Exhaust Depot cold side pipe
Stage 1
TurboXS boost controller

Any help would be greatly appreciated.
Zach
 

·
Registered
Joined
·
835 Posts
well, i can tell you might have a little leak with one of your vacum lines, but from experience when you have a leak you most likly will know bec you prob wont be able to boost past 10psi. just double and triple check all you vacum lines to you bc and everywhere else to make sure you dont have anything crossed. how do you have your bc ran green or black line off turbo?
 

·
Registered
Joined
·
144 Posts
Discussion Starter #7
I just moved the adjusment nut and the jamb nut closer together and was hoping that was the problem since they were so far from each other. But it seemed only to slow down the boost droping until about 4000 rpms then it drops crazy fast.
 

·
Registered
Joined
·
835 Posts
hmm, i know my buddy has a problem like this but i know it is bec of his stock w/g with boost controller. just double check the w/g lines. make sure there isnt any tears or pin holes.
 

·
Registered
Joined
·
144 Posts
Discussion Starter #9
thanks dude..im deff going to go ahead and double check everything and worse comes to worse I have to get a boost leak tester.

Thanks again
Zach
 

·
Registered
Joined
·
835 Posts
lol..good luck with that man...also just too eliminate that is isnt your w/g (which it prob isnt) detatch your bc and run the w/g....set it at 14 psi and see if that is boosting fine
 

·
Registered
Joined
·
835 Posts
ohh, also do you have a bleeder on the bc???? i know that if there isnt or air isnt getting out of it that will make you spike like that
 

·
Registered
Joined
·
838 Posts
All i can think of is to put a boost leak tester on it, you'd be surprised....when i finally did mine i had 9 leaks but the car wasn't really running bad at all.....and i had a turbo xs bc on mine but took it off and put a turbo smart on there....it's alot better and easier to set the boost where you want it
 

·
Registered
Joined
·
11 Posts
have a turbo smart boost controler

Lethal_Whisper said:
All i can think of is to put a boost leak tester on it, you'd be surprised....when i finally did mine i had 9 leaks but the car wasn't really running bad at all.....and i had a turbo xs bc on mine but took it off and put a turbo smart on there....it's alot better and easier to set the boost where you want it
i have a turbo smart and i do not know how to hook it up if you could help me email me or just let me know email is [email protected]....


I have s/1 greddy type rs bov, perrin boost tube, msd coil pack, 8.5 mm plug wires, dogbone mm, upper strut bar and the turbo smart boost controller but dont how to hook it up... THANKS
 

·
Registered
Joined
·
838 Posts
joshawa said:
i have a turbo smart and i do not know how to hook it up if you could help me email me or just let me know email is [email protected]....


I have s/1 greddy type rs bov, perrin boost tube, msd coil pack, 8.5 mm plug wires, dogbone mm, upper strut bar and the turbo smart boost controller but dont how to hook it up... THANKS
I'll email you instructions.
 
1 - 15 of 15 Posts
Top