Dodge SRT Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2,563 Posts
Discussion Starter · #1 ·
I went to auto zone today and got the hose clamps and a valve stem. The radiator hose they had just didn't look large enough to me...

So off to Home Depot, I got a flexible pipe and a PVC cap that I thought would work out well, then I thought... hmmm, isn't the silicone hose that connects the K&N CAI to the turbo about the same thing as a rubber hose...

aha! No more rubber hose needed :thumbsup:

So I hook everything up and start the test... it doesn't seem to be holding pressure. Haha, hey dumbass, plug that hose that was connected to the CAI! :rofl:

Ok, bolt in hose, no more leak there! I then had my sister pressurize the system while I watched the boost gauge...1....2....3 PSI.... 3 PSI??? :WTF:

So I decide to pressurize the system so that I can listen for leaks... there it is! Sounds like it is coming from the Mopar BOV! Insert hand, yep... I can feel air rushing out underneath the turbo from the backside of the BOV...

Time to tighten the bolts........... ok, test again... still 3 PSI, OK I am pissed now.... the air is still leaking out from the BOV.... tighten some more.... tighten....tighten.....SNAP!! :ninja:

The front-most bolt snapped right off! SHIT SHIT SHIT SHIT...

Now to sum the rest up for you, I no longer have the BOV and I still have the damn boost leak! I was tired of working and it was getting late so I put everything back together and took a test ride. Runs as good as ever (boost spikes to 17-18 and drops to 15...

I think the leak might be from the hotside pipe where it connects to the turbo. Guess what I get to do tomorrow!? haha
 

·
Registered
Joined
·
333 Posts
Watch out for those worm clamps........you can over tighten them and break them pretty easy. :eveilgrin
 
1 - 2 of 2 Posts
Top