Dodge SRT Forum banner

1 - 5 of 5 Posts

·
Banned
Joined
·
460 Posts
Discussion Starter · #1 ·
Yesterday I installed my E.D. Hardpipe kit, and HKS SSQ BOV, and AGP bop. Now, this morning i went outside and tightened down the hks bov screw to tighten it so it wouldnt blow off under vacuum. But I tightened it down all the way down to 2 threads left and its STILL blowing off under vacuum. Now today I drove with it like that and it was fine till i decided to floor it and when I floored it it just held at 4000 RPM's and wouldnt go anywhere till I let off the gas and shifted gears...also, when I give it some gas to accelerate normally, the car makes a whisteling sound and the BOV doesnt even blow off any pressure anymore...is my block off plate loose and not sealing or what? I used RTV Grey Sealant to seal it. For the T fitting for the BOV I used all metal hose clamps so it wouldnt leak...can you guys diagnose what the problem is? Thanx all in advance.

Kenny
 

·
Registered
Joined
·
336 Posts
I would go over everything with a fine tooth comb. Something is not sealing. The BOP shouldn't need goup if you have a gasket, but since you have it there that should seal.
 

·
Registered
Joined
·
1,843 Posts
for starters you want your bov to open up as easily as it can. the hks won't leak under pressure so don't worry about that. the reason you want it to blow off under vacuum is if you don't let it do that it causes turbo stall which ***potentially*** could be damaging over time, and it also can increase spool up time during off throttle to on throttle. as for the 4000 rpm thing i dunno, loosen that screw up all the way, make sure the lock nut is down though
 

·
Banned
Joined
·
460 Posts
Discussion Starter · #4 ·
yea i dunno what it is...you can hear this whisteling noise spool up with the turbo...and its REALLY annoying...
 

·
Banned
Joined
·
460 Posts
Discussion Starter · #5 ·
k well...i solved half the problem...the pasangerside (hotside i believe) intercooler pipe blew off the intercooler itself...put that back on but its still blowing off under pressure...and no more whisteling noise...
 
1 - 5 of 5 Posts
Top