Dodge SRT Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
3,246 Posts
Discussion Starter #1
Ok so I finally got around to doing a boost leak test, after tightening up my lower side of the cold pipe I was hoping to be able to hold boost.............. but now it seems to be leaking around my Zzap TB and it won;t hold any boost! Funny since the car drives fine...................... anyone have any advice on how to fix this problem with the Zzap??
 

·
Registered
Joined
·
8,890 Posts
Funny I just got my zzapp, did a boost leak test and Its tight like a frogs ass.

I used a mopar black rtv sealant when installing mine, no problems and it hauls ASS!!
 

·
Registered
Joined
·
12,239 Posts
they all leak but the zapp's leak like a mofo out the throttle side of the butterfly shaft
 

·
Registered
Joined
·
8,890 Posts
thunder6g said:
RTV where? Did you just buy it? I got mine a LONG LONG time ago when they first came out. I need some help.................. I think Aaroneon knows more.......... **PMing him**
I got it from the dealership, they gave me a free tube.

pressure tested to 22psi
 

·
Registered
Joined
·
2,156 Posts
Well ...

The car drives just fine because it doesn't leak when your car is running. Makes a boost leak check impossible though :stab:
 

·
Registered
Joined
·
12,239 Posts
Yep i couldnt leak test past 10 psi till i fixed it.....Search "dasmopar zapp fix" and you should be able to find it. srt4police does a good write up in there for what he did with his lorenzo.
 

·
Registered
Joined
·
12,239 Posts
The only thing I can think of is they heard of the problem and changed the bearings they were using. The bearings that are in the ones in question you can blow through with your own mouth "yes i tried dasmopar dared me". When you put the silicone in your basicly still going to leak but WAY WAY less.
 

·
Registered
Joined
·
3,246 Posts
Discussion Starter #12
dansrt4 said:
When you put the silicone in your basicly still going to leak but WAY WAY less.
Thats cool, I was just really worried I would have to buy a new one! I'm not wanting to get in on that since I'm planning on a ported turbo soon. Just looking for a way to make this one work enough to boost leak test the car so I can fix the other problems............. thanks for the info on the "fix" I searhced all last night but I think the forum crashing screwed everything up
 

·
Registered
Joined
·
5,850 Posts
i had an issue with mine i sent it back and they fixed it but then the leak came back on the shaft.. found out that when the car heats up the bearings seal and the leak goes away.. but i found when the engine is cold and i do a boost check it leaks like crazy
 

·
Registered
Joined
·
3,246 Posts
Discussion Starter #18
hmmm well I pm'ed Aaronneon and dansrt4 and no reply yet.............Das is next.
Bacardi the car was "warm" I drove it home and the valve cover and everything was still way too hot to touch when I tried to do the boost test. No dice first it was the cold side pipe and now the TB, and it won't hold any boost! I'm gonna take it off and see what I can figure out
 
1 - 20 of 22 Posts
Top