Dodge SRT Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
I am having some boosting issues, and I'm pretty sure it's not normal. But I just bought the car recently, and am thinking possibly it is supposed to do this. Anyways, when I got WOT, the boost quickly builds to about 12 psi. Then from about 2.5k to 4k rpm, the boost stays at 12. Then after about 4k rpm the boost continues to build to about 16-17. The car definitely does not feel like it has the power that it should. The only mods are: cat-back exhaust, intake, and dsp. I am wondering if this is just the pcm limiting boost to stop wheel spin, but I don't think it is. Please help. Thanks.
 

·
Registered
Joined
·
58 Posts
That is not normal. When I go wot I spike about 15 and then it drops to 13 at redline. You should boost leak test and zip tie all the vac lines. Check all clamps for your hot side + cold side pipes that go to your intercooler. If you don't have t-bolt clamps get some of those too.
 

·
Fresh Meat Moderator
Joined
·
16,395 Posts
With the performance tune on the DSP, you should be spiking 20 PSI at least.

Do a boost leak test and verify vacuum lines are all in the correct spots.
 

·
Registered
Joined
·
690 Posts
Both of those ^
and like said get the t-clamps, I had a problem with my intercooler pipe blowing off under boost and it had those junk worm gear clamps.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #5
I did a boost leak test, and it definitely will not even hold anything above 10 psi. Whenever I get above 10 psi I can see the wastegate arm moving and it appears that the wastegate is just dumping out all the air. I checked all the vacuum lines with the diagram on here and they are all lined up correctly. Does the wastegate arm moving indicate that it is dumping out all the air? What would cause it to do this?
 

·
Registered
Joined
·
248 Posts
Is it a stock wg? I had same problem but I was off pcm control on a forge wg and the wg was toast. Bought a new agp and it fixed everything. Spiked to 19 slowly dropped to red line

Sent from my HTC Sensation Z710e using AutoGuide.Com Free App
 

·
Registered
Joined
·
21 Posts
Discussion Starter #7 (Edited)
It is the stock wastegate. What i could try is unplugging the vacuum line to the wastegate and doing a pull and seeing if anything changes. Would this be an indicator of whether the wastegate is bad?
 

·
Registered
Joined
·
33 Posts
Hijack / Zombie thread, I know. But I feel my boost question doesn't justify a new thread... I know nothing about the history of my car. I've been slowly fixing things since I bought it a couple months ago. I bought a new 03 back in the day and this 04 acts a bit different than I remember. First and second gear I get about 10 or 11 psi. And third it will go about 12. 4th and 5th it will spike to 15 (i've seen 16 a time or two) and then starts backing off. As far as I can tell, the car is on a stock tune. It appears to be stock under the hood except I have installed an injen intake since the PO was using a hacked up stock intake minus the airbox. It has a blow off plate too. I don't think I have any major boost leaks (found the one on the cold side intake tube and fixed it).
This car was a repo, so I am expecting to find more surprises as I go. It has about 166k now and it seems to run perfect. No smoke or knock or anything like that. Leaks a little oil on the passenger side, I'm thinking cam seals and maybe the oil pan. I can see some gray rtv here and there so I am wondering if it may have been rebuilt or had a new engine installed.

Anyhow, I'd like to know if it seems normal for the pcm to be limiting boost in second and third even though the car isn't built
 

·
Registered
Joined
·
33 Posts
anyone? ran the car today and it is definitely limiting boost in third. about 11 or 12 in third and then in fourth it spikes to 15 or 16. I know that my 03 did not limit boost in 2nd or 3rd. Did they change that for 04?
 

·
Registered
Joined
·
3,911 Posts
Cold weather will reduce boost if you PCM is managing boost.
This is normal.
Cold air is denser so less boost is needed to achieve target torque.
 

·
Registered
Joined
·
33 Posts
Cold weather will reduce boost if you PCM is managing boost.
This is normal.
Cold air is denser so less boost is needed to achieve target torque.
I understand that the PCM will limit boost when it's cold, believe me I read 30 threads about boost issues. What i'm curious about is why it's limiting boost in third gear. When I bough one of these new in 03, that car only seemed to limit boost in first gear. The 04 i'm driving now limits in first, second, and third and will spike to 15 only in fourth and fifth.
 

·
Registered
Joined
·
3,911 Posts
I understand that the PCM will limit boost when it's cold, believe me I read 30 threads about boost issues. What i'm curious about is why it's limiting boost in third gear. When I bough one of these new in 03, that car only seemed to limit boost in first gear. The 04 i'm driving now limits in first, second, and third and will spike to 15 only in fourth and fifth.

Sounds like the WGA.
Could be the WGA diaphragm leaking.
Try another WGA.
I understand that the PCM will limit boost when it's cold, believe me I read 30 threads about boost issues. What i'm curious about is why it's limiting boost in third gear. When I bough one of these new in 03, that car only seemed to limit boost in first gear. The 04 i'm driving now limits in first, second, and third and will spike to 15 only in fourth and fifth.

Thanks for providing more information!
Yeah, the WGA is suspect at this point based on everything you've said so far.
 

·
Registered
Joined
·
3,911 Posts
Sounds like the WGA.
Could be the WGA diaphragm leaking.
Try another WGA.



Thanks for providing more information!
Yeah, the WGA is suspect at this point based on everything you've said so far.
ps I think the WGA diaphragm may only be applicable to the AGP WGA.
Your OEM stock WGA is sealed so it would be tricky to get at the internals.

Yeah, see if you can borrow or buy a new WGA.
 

·
Registered
Joined
·
33 Posts
ps I think the WGA diaphragm may only be applicable to the AGP WGA.
Your OEM stock WGA is sealed so it would be tricky to get at the internals.

Yeah, see if you can borrow or buy a new WGA.
Ok, will do. Thanks for the tip! I will see if I can track down a new stock WGA. As long as I stay on PCM boost, there is no real benefit to using an AGP or other upgraded one, right?
 
1 - 15 of 15 Posts
Top