Dodge SRT Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
123 Posts
Discussion Starter · #1 ·
I have an 04 w/ stage1 MPx Intercooler, turbonetic BOV, AGP ajustable W.G got it about a month ago and was running great 13-15 psi now it changes by its self sometimes 5psi sometimes 13psi anyone have any Ideas??? I check for boost leaks -none vacume line are the same from when I got it Black- W.G Green-Turbo/spliced to BOV... any help would be appreciated
 

·
Registered
Joined
·
267 Posts
SRT4NEMESIS said:
I have an 04 w/ stage1 MPx Intercooler, turbonetic BOV, AGP ajustable W.G got it about a month ago and was running great 13-15 psi now it changes by its self sometimes 5psi sometimes 13psi anyone have any Ideas??? I check for boost leaks -none vacume line are the same from when I got it Black- W.G Green-Turbo/spliced to BOV... any help would be appreciated
Are you using PCM controlled boost? In other words, is the AGP WGA hooked up to the stock vac lines or is it directly hooked to the boost source on the turbo?
 

·
Registered
Joined
·
267 Posts
ojedel01 said:
SRT4NEMESIS said:
Are you using PCM controlled boost? In other words, is the AGP WGA hooked up to the stock vac lines or is it directly hooked to the boost source on the turbo?
I see you wrote WGA to Green and spliced in or something...looks like you are using PCM controlled boost. The only thing I can think of is a boost leak you can't find yet. Something must be leaking somewhere. Check your brake boost line. Mine was really loose.
 

·
Registered
Joined
·
256 Posts
yea its the pcm. I've noticed that before when I was at high rpm and punched it. I lost like 3 pounds. I was like wtf, downshifted hit it again, and normal boost levels. Its gthe stage 1 pcm. I get that sometimes, like once every 100 WOTS..
 
1 - 6 of 6 Posts
Top