Dodge SRT Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
1,199 Posts
Discussion Starter #1
Hey i just got a 2004 dodge srt-4, car has 82,000 miles.

The stock boost Gauge doesnt read 0 when the key is out of the egnition. the little pointer is at 2psi instead of 0.

Does this mean i have a boost leak, because when it holds at 14 - 15 psi im really only getting 12 psi?

Thanks.
 

·
Registered
Joined
·
437 Posts
yes your gauge is bad. get a auto meter 30/30 if you plan on modding the srt

GL
 

·
Registered
Joined
·
437 Posts
an autometer like what company and where can i find this? u dont think i should get the stock gauge again?
autometer is the company... just research a lil/// 30/30 boost gauge

Just buy another one and replace it?

how would i do that just take out the wires from the old gauge and plug it into this 1?
yep its a direst fit.. you gotta take off the dash and unscrew the stock pod from the dash and take out the stock gauge and put the 30/30 in the stock pod and button it up! lol

there you go:thumbsup:
 

·
Registered
Joined
·
437 Posts
NP... i picked mine up on here for 35 bucks shipped... just make sure if you buy used its not fubared lol... it has to sit on 0 when the car is off!!
 

·
Registered
Joined
·
1,199 Posts
Discussion Starter #10
So if its out of the car when i meet up with the guy to buy it hold it still and make sure its on 0?
 

·
Registered
Joined
·
437 Posts
So if its out of the car when i meet up with the guy to buy it hold it still and make sure its on 0?
Yep if the car is off or its in his hand it has to be on 0:thumbsup:
 

·
Registered
Joined
·
437 Posts
he saying the stock gauge is a piece of shit and they should have put 30/30s in our cars
 
1 - 17 of 17 Posts
Top