Dodge SRT Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
143 Posts
Discussion Starter · #1 ·
I recently put my car back to stock but i still have my Turbo XS MBC. Anyways, when i first got the car i could boost it up to 17 psi and have it drop to like 12-13 at redline with the stock wastegate. Now, no matter how many times i turn the BC, it wont boost past 13. Anyone have any ideas as to what this could be?

Thanks
Bryan
 

·
Registered
Joined
·
5,217 Posts
a reputable brand name? that case, it could be defective.
 

·
Registered
Joined
·
966 Posts
Bryan said:
I recently put my car back to stock but i still have my Turbo XS MBC. Anyways, when i first got the car i could boost it up to 17 psi and have it drop to like 12-13 at redline with the stock wastegate. Now, no matter how many times i turn the BC, it wont boost past 13. Anyone have any ideas as to what this could be?

Thanks
Bryan
Seems to me like that is just your PCM reducing boost. Plus, the fact that you are using the stock wastegate doesn't help. Seems to me like the MBC was working fine.
 

·
Registered
Joined
·
2,901 Posts
unhook your battery for a little while, then put the battery cable back on. that should make everything back to normal
 

·
Registered
Joined
·
143 Posts
Discussion Starter · #6 ·
i sure hope so. i still have my AGP WGA but im not sure if im gonna put it back on or what. Ive taken the battery off quite a few times but maybe ill leave it off for a while longer. im also gonna change my plugs again.
 

·
Registered
Joined
·
966 Posts
Remove and cap the black and green lines of the #2 solenoid, and then run the MBC from either the turbo or the manifold.
 

·
Registered
Joined
·
361 Posts
I had the same problem last week. I think you have it hooked up the universal way. After about week or so the computer goes back to stock settings. anyhow, go to www.turboxs.com and look under the srt-4 boost controller section and there is a diagram of how to hook up the turboxs boost controller specifically for our cars.
 

·
Registered
Joined
·
8,752 Posts
Apex'i

DippinOnV8's said:
Anybody have an Apex'i AVC-R installed in their cars ?
I have one on my car and love it.Although if you think you might at some point get the Greddy E-manage then go ahead and get the Greddy Boost controler.I have had no problems with my A'pexi BC except for a strange lack of traction.
 

·
Registered
Joined
·
2,852 Posts
elctrcblusrt467 said:
It sounds like you don't have it hooked up right because if you did, the computer would have nothing to do with how much boost is going to the wastegate actuator
Correct. You might wanna follow this again to see if there is anything you might have missed.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top