Dodge SRT Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
732 Posts
Discussion Starter #1
hey guys big problems with the car right now when it warms up and i step on it it just stutters and doesn't really move and BILLOWS white smoke :crying:
 

·
Registered
Joined
·
732 Posts
Discussion Starter #3
ya from what i've heard its the head gasket gonna pull the lower coolant hose and inspect for oil (fingers crossed)
 

·
Registered
Joined
·
7,310 Posts
If a head gasket goes out it will not always cause water and oil to mix and vice versa. It's possible for it to leak between cylinders, develop external leaks, or burn coolant or oil. What type of things have you been doing to the car that could cause a head gasket problem? Also have you pulled the spark plugs to see how they look? You can tell a lot by checking if they're oily, have rust on them, etc.
 

·
Registered
Joined
·
12,239 Posts
mustangdude20 said:
ya from what i've heard its the head gasket gonna pull the lower coolant hose and inspect for oil (fingers crossed)

Also if it mixes usually your oil is white and milky
 

·
Registered
Joined
·
725 Posts
you need to check compression and pressure test radiator/coolent system. if you dont know how to do it take it to a qualified mech. :eeeek:
 

·
Registered
Joined
·
732 Posts
Discussion Starter #8
getting ready to drain coolant today and perform a compression test i'm fairly certain its the head gasket as its all the normal signs of it i was just so panic'd yesterday i started asking for help from everyone everyone that's had one go said mine sounds the exact same as when it happened to them

cause my car has been running extremely warm and i added some coolant but i suspect then along with a slight detonation problem due to a faulty regualtor i was using pushed it past the limits
 

·
Registered
Joined
·
732 Posts
Discussion Starter #9
on the bright side i was planning to put a ported head and custom intake manifold on in the next couple of weeks as well as a turbo swap so its just gonna happen sooner now :thumbsup:
 

·
Registered
Joined
·
732 Posts
Discussion Starter #10
:crying: nevermind i just pulled the plugs they were covered in oil
looks like i'm building the motor too :flame:
 

·
Registered
Joined
·
732 Posts
Discussion Starter #11
haha figured it out my turbo seals and bearings are SCREWED thank god its an easy fix
 
1 - 11 of 11 Posts
Top