Dodge SRT Forum banner

1 - 6 of 6 Posts

·
Registered
2003 Dodge Neon SRT-4
Joined
·
16 Posts
Discussion Starter #1
Hey guys so after boosting my car hard for the first time since I've had it couple months (coronavirus blocked me from registering and stuff) but when I got home maybe after 1 hour it started whining and squeaking, so I go and check and my belt was slipping off the powersteering pump pulley. I checked the other pulleys but they are fine. After the tensioner the P/S is the only one like that. The ac compressor isn't loose. I'm new to these car so I'm not that knowledgeable, but I'm pretty sure it is the tensioner, it is rusty and my car had it engine replaced at 76k miles now it has 140k, so i doubt they ever changed it. The P/S is slightly to the right but that might be normal idk. If you guys can give me some tips on what to check to make sure it isn't anything else. (At the moment I can't take the wheel off due to a stripped lugnut but I will be taken care of that).thanks guys for stopping by!
 

·
Registered
Joined
·
4,744 Posts
I'd start by replacing it since it's fairly cheap. Modern Performance has it. On the topic of the tensioner... when was the timing belt done? If you don't know, or if it's due, I'd do that as well.

Only other thing I can think of is you have a coolant leak and it dripped onto the belts; common source of belt squeak in these. It should be obvious if you have a coolant leak though.
 

·
Registered
2003 Dodge Neon SRT-4
Joined
·
16 Posts
Discussion Starter #3
I'd start by replacing it since it's fairly cheap. Modern Performance has it. On the topic of the tensioner... when was the timing belt done? If you don't know, or if it's due, I'd do that as well.

Only other thing I can think of is you have a coolant leak and it dripped onto the belts; common source of belt squeak in these. It should be obvious if you have a coolant leak though.
I recently did the coolant and I'm pretty sure it spilled on it. But thanks, yeah either way I bought the tensioner and new belt a few days ago
 

·
Premium Member
Joined
·
4,248 Posts
since you will already be in there, you might also consider replacing (if its never been done) the 4th motor mount. Its in the frame rail on the passenger side.

That wont have anything to do with your belt issue, but it might save you some headache down the road.
 

·
Registered
2003 Dodge Neon SRT-4
Joined
·
16 Posts
Discussion Starter #5
Yeah, I got to replace all the motor mounts either way they are all garbage, shaking around the whole time. Thanks for the info man appreciate it very much!
 

·
Registered
2003 Dodge Neon SRT-4
Joined
·
16 Posts
Discussion Starter #6
I'm back guys, new belt and belt tensioner installed but the thing is everytime I start it, it slips off halfway. Idk if it could be the crank pulley or what. The tensioner is good it guides it but once it reaches the powersterring it starts to slip and goes back to normal. Could it just be my P/S pulley? My uncle who also has a SRT-4 did his maybe a 1 year ago and has tbe same problem sometimes.
 
1 - 6 of 6 Posts
Top