Dodge SRT Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
2,426 Posts
Discussion Starter #1
I do think it's leaking somewhere cuz it's hard to get a decent boost unlike the stock setup. Butt feel is rather disappointing. :cry:

I took off the UPP assembly last night just to tighten the HKS BOV (bolt at the back of it). It felt better after that...but now it's back to fading boost. Very good vacum though.

When I hold in 2nd gear (or 3rd) at around 4k rpm at a steady low speed (kinda like when you are waiting to get a clear shot of cutting off a slow traffic), at times, all of a sudden it loses power/boost.

I think if I tighten the clamps any further on the pipe they would snap.

Any ideas? What should I check or where should I start looking?

Thanks.
 

·
Registered
Joined
·
2,426 Posts
Discussion Starter #2
It seems that the turbo has to ward very hard just to create enough boost...but still not enough compared to the stock setup.
 

·
Registered
Joined
·
1,843 Posts
i had something similar, dunno if you read that topic. my leaking was coming from the intercooler sleeve. just make sure the rubber is pushed far over each pipe, the clamps on the upp can be tightened a lot cause that pipe isnt breaking. the aluminum on the other hand might, so get it pretty tight but dont go overboard.
 

·
Registered
Joined
·
2,426 Posts
Discussion Starter #4
NeonWaSp said:
i had something similar, dunno if you read that topic. my leaking was coming from the intercooler sleeve. just make sure the rubber is pushed far over each pipe, the clamps on the upp can be tightened a lot cause that pipe isnt breaking. the aluminum on the other hand might, so get it pretty tight but dont go overboard.
Thanks. I'll check those clamps again. I may need to go to the hardware store and get some extra clamps just incase.

Any easy way to test for leakage?
 

·
Premium Member
Joined
·
5,578 Posts
get it fixed?
 

·
Registered
Joined
·
1,843 Posts
hard to say since it doesnt make much boost without moving (under load) i guess hang your head out the window, hammer it, and if you hear a lot of air rushing out then it isnt fixed yet :p
 

·
Registered
Joined
·
2,426 Posts
Discussion Starter #7
Okay, now it's much better!

* Took off the UPP (with the bov tightly installed in it) and adjusted the back of the BOV (I think that nut back there changes the sounds of the phhsst, too. Not sure).

* Went to Home Depot and bought 5 new clamps (#75 in green box; got an extra just in case). They seem to be FAR stronger than the ones that came with the kit. I tightened them much more that the ones with the kit without breaking them. I could not do that with ATP ones.

* While the unit still out, I went ahead and tighten the clamp on the pipe by the TB side. This is better than doing it while under the car.

* Used zip ties everywhere I could use it; total of 6; one at each end.

I also let all the clamps bolts' top face down for easy access from the under the car.

So far so good! We'll see how long this holds.
 

·
Registered
Joined
·
2,426 Posts
Discussion Starter #8
NeonWaSp said:
hard to say since it doesnt make much boost without moving (under load) i guess hang your head out the window, hammer it, and if you hear a lot of air rushing out then it isnt fixed yet :p
I did that and I felt like I was the character Jim Carey playd on one of his movies...you know, he he stuck his head out the window while driving and ended up with all those bugs in between his teeth. :lol:

Anyway, all I hear out there is the sweet sound of the turbo spoooooolin! :twisted:
 

·
Registered
Joined
·
1,843 Posts
SilverBullet said:
NeonWaSp said:
hard to say since it doesnt make much boost without moving (under load) i guess hang your head out the window, hammer it, and if you hear a lot of air rushing out then it isnt fixed yet :p
I did that and I felt like I was the character Jim Carey playd on one of his movies...you know, he he stuck his head out the window while driving and ended up with all those bugs in between his teeth. :lol:

Anyway, all I hear out there is the sweet sound of the turbo spoooooolin! :twisted:
hahahha yeah as i was typing that out that was the exact vision that popped in my head. glad to hear its all together and working well!
 

·
Registered
Joined
·
2,426 Posts
Discussion Starter #10
:lol:

I went for a few miles spin at lunch today and it pulls pretty hard...decent wheel spin on 2nd from 30MPH roll. :twisted:
 

·
Registered
Joined
·
1,826 Posts
exactly how much did you tighten the bolt on the back of your HKS BOV.... because i have one, and i'm thinkin i need to do the same thing... :?
 

·
Registered
Joined
·
7,982 Posts
SilverBullet said:
:lol:

I went for a few miles spin at lunch today and it pulls pretty hard...decent wheel spin on 2nd from 30MPH roll. :twisted:
The things I could only wish for :)
 

·
Registered
Joined
·
2,426 Posts
Discussion Starter #13
mdhavi18 said:
exactly how much did you tighten the bolt on the back of your HKS BOV.... because i have one, and i'm thinkin i need to do the same thing... :?
I think I left about 1/16" between the bolt head and the top of the nut.
 

·
Registered
Joined
·
2,854 Posts
I went for a few miles spin at lunch today and it pulls pretty hard...decent wheel spin on 2nd from 30MPH roll.
Oh yes I love those words, I want the car now dammit!.
 

·
Registered
Joined
·
2,426 Posts
Discussion Starter #15
I installed the stock piping again...and saw the spike of boost. Went to Home Depot and grab more of the clamps. They seem to fit better as they are not as wide to cut rubber fittings. And I can tighten them up nicely...but can only use them one or twice....so from now on I avoid messing with it...or simply get a new set of clamps when I need.

Also, I loosen the back of the HKS BOV. It sounds pretty cool now. Ricers chase me around and drive side by side and look (or don't look as if they have it all good.)..until I let 'er breath... Psssshhhht! Ah! Enough to make them dare not to pass.

WRX guy was tempted by his buddy passenger to show me I guess...but the driver just look carefully and smiled and shoke his head and said no to his bud. Of course, this is after I let my "NEON" go psssssssssssssssssssssssssssshht! My bro and I just laughed. :lol:

This was this weekend.
 
1 - 15 of 15 Posts
Top