Dodge SRT Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
My son's 05 srt4 blows the asd fuse as soon as you turn the key on,if you put a 30 amp fuse in,it will run for a few seconds then blow the fuse,the coil started smoking and cracked by number 1 terminal,any suggestions as to where to look for the short,it has a brand new engine harness as well as a brand new fuse box harness,thank you for your help
 

·
Registered
Joined
·
5,756 Posts
Why did the car get a new engine harness and fuse box setup? Did it blow that fuse prior to those new parts? Check all the grounds. Sounds like something isn't wired right.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #3
Why did the car get a new engine harness and fuse box setup? Did it blow that fuse prior to those new parts? Check all the grounds. Sounds like something isn't wired right.
My son wrecked his 04 srt4,I switched everything from it to our 05 acr,I put a untouched original engine harness on it because the other one was chopped up and doing the same thing,I have checked and cleaned all grounds and double checked everything,is the fuel pump pulled ng to many amps?it will run for a minute or so before it blows the fuse
 

·
Registered
Joined
·
5,756 Posts
does the car have a fuel pump rewire done to it?
So he wrecked his 04 SRT and you put everything to a 05 Neon SRT? Why? What was wrong with the 05 Neon SRT ?

I am sure someone else will chime in with more electrical knowledge then me. If you don't get much responses here try Neon SRT groups on Facebook or perhaps even 2gn.org or neons.org
 

·
Registered
Joined
·
23 Posts
Discussion Starter #5
does the car have a fuel pump rewire done to it?
So he wrecked his 04 SRT and you put everything to a 05 Neon SRT? Why? What was wrong with the 05 Neon SRT ?

I am sure someone else will chime in with more electrical knowledge then me. If you don't get much responses here try Neon SRT groups on Facebook or perhaps even 2gn.org or neons.org
No it does not have the pump rewire,and the 05 was a parts car and needed put back together,I changed everything and mean everything from the wrecked 04.it blows the fuse as soon as you turn the key on if the fuse is less than 30 amps ,thank you for your response
 

·
Registered
Joined
·
2,709 Posts
No it does not have the pump rewire,and the 05 was a parts car and needed put back together,I changed everything and mean everything from the wrecked 04.it blows the fuse as soon as you turn the key on if the fuse is less than 30 amps ,thank you for your response
if the original car had a fuel pump rewire, and you swapped an non.. it will burn that relay and wires in the fuse box.. i have first hand knowledge .. a 255 is over the amp rating of the stock pump
 

·
Registered
Joined
·
23 Posts
Discussion Starter #7
if the original car had a fuel pump rewire, and you swapped an non.. it will burn that relay and wires in the fuse box.. i have first hand knowledge .. a 255 is over the amp rating of the stock pump
No neither car has had it,it pops the fuse as soon as you turn the key on,unless it's a 30 amp then it starts and runs for a minute before it pops it
 

·
Premium Member
Joined
·
4,647 Posts
generally overfusing is NOT the way to troubleshoot unless you want to smoke something.... unplug the noise suppressor and see if the fuse still pops. Do not let that wire ground out on anything while doing this test.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #9
I agree,and it only pops when the coil is unhooked,I checked the coil and it is dead on cylinder 1 and 4 so the coil is bad,now whether that causes the fuse to blow,remains to be seen,I unhooked the ground wire and the fuel pump plug and it still popped, unhooked the coil, didn't pop.
 

·
Premium Member
Joined
·
4,647 Posts
sounds like you're on to something. Grab another coil and retest.
 
1 - 10 of 10 Posts
Top