Dodge SRT Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
386 Posts
Discussion Starter #1
AGP turbo kit "Evolution Waste Gate" and turbo xs dual boost controller how to hook?

I just got a the turbo XS dual boost controller. How to I hook it up to the Evolution waste gate.
I am so confused.
 

·
Registered
Joined
·
386 Posts
Discussion Starter #3
Leave the top port open, and run the boost controller to the side port on the WG.

There are two ports on the WG right. and they are both on the side. You mean run a line from the pressure side of the turbo to the inlet on the boost controller, then run a line to the lower nipple on WG, and leave the top nipple open?
 

·
Supporting Vendor (Gold)
Joined
·
2,023 Posts
ricardoa1 said:
There are two ports on the WG right. and they are both on the side. You mean run a line from the pressure side of the turbo to the inlet on the boost controller, then run a line to the lower nipple on WG, and leave the top nipple open?
That is correct.
 

·
Registered
Joined
·
386 Posts
Discussion Starter #5
I set it up just like you guys are saying. On the fist stage I got it to go up to 13psi~. On the second stage I got the thing to go 16~ but The adjustment screw is almost out. How can I get it to go 20psi or more.
 

·
Registered
Joined
·
386 Posts
Discussion Starter #10
I guess I have to, But that defeats the purpose doesnt it?
I was hoping to have 1st stage very low for traction purposes.
 

·
Registered
Joined
·
386 Posts
Discussion Starter #11
I got both almost out of adjustment. I dont build more then 18 psi.
Am I doing somthing wrong?
Could I possibly have the wrong spring in the waste gate?
What spring should I be using?
 

·
Registered
Joined
·
2,138 Posts
stiff spring in the second stage, weaker spring in the first stage. but i dont know if they have different springs in a turbo xs duel boost controller. if they do you might have the wrong spring in the wrong stage.
 

·
Registered
Joined
·
386 Posts
Discussion Starter #13
I meant the waste gate.
There are no springs in the xs boost controller only a bleed system that will allow it to bleed more and more as you unscrew the adjustment screw.

I am out of adjustment on the boost controller on both the low and high and only get 18psi in the second stage. Note that the second stage uses the first stage bleed and compounds on top of it.

So I dont know if the spring in the waste gate is too strong or weak?
I don't know if thats the problem.
 

·
Registered
Joined
·
732 Posts
the boost controller does have springs in it almost all manual boost controllers are built just like the ones you can make out of plumbing fittings except look nicer and are slightly simpler to use

and next thing why run an 9-11 psi spring if you want atleast 13psi in your FIRST stage?
put a higher psi wastegate spring in
 

·
Registered
Joined
·
386 Posts
Discussion Starter #16
Will a restrictive intake cause low boost. Sounds like a dumb question I know.
I took off my intake and installed just a filter on the turbo, I was having problems with the perrin intake.
The filter is somewhat small since there is little space back there.
I will be getting a AGP intake when funds allow.

I will try to take off the filter and go for a run to see if it helps.
But I triple checked the boost controller and I have done boost leaks recently and everything turns out to be ok.

I do get alot of surge when PTBoosting, I didnt get it as much when I had an electronic boost controller.
 

·
Registered
Joined
·
386 Posts
Discussion Starter #17
Well, its not the intake, I can hear the WG open so the boost controller has got to be the problem or the WG spring is too low. I just dont want to go and buy the high performance version and have the same limitations. I dont think there is enough adjustment on the regular version.

I didnt have these problems with the HKS EVC.

Any recomendations guys?
 

·
Registered
Joined
·
386 Posts
Discussion Starter #20
I called turbo XS, The regular version DS should be good for 30~ Psi. I told them what the problem is, and they told me that it could either be a clogged boost controller or a busted turbo. There is no spring and ball in the unit it is simply a bleed only boost controller.

I am so confused, I dont think it is any of the two. I took the line of the WG off and no boost reference going to the WG. Went for a ride and boost spiked and climed to dangerous levels, not smooth either it made fast intermetent noises while building the boost. The BOV was probably bleeding some since I was not 100% WOT. the turbo spins freely and has no side movement.

I took the boost controller apart and I dont see anything clogging it..

Then I read that the 10lbs spring on the WG is good for 30psi with a boost controller.

I dont know guys anything?
 
1 - 20 of 25 Posts
Top